Vision Spinner issue

Discussion in 'New Members Forum' started by Conduct0r, Oct 11, 2013.

Thread Status:
Not open for further replies.
  1. Conduct0r

    Conduct0r New Member

    Hi all. avid vap-head, first time poster, hence the noob page. having an issue with my vision 1500 mAh. I bought the battery as my first base, and have since upgraded to a MOD, but still use it as a back up. today, it was working like a champ after i killed my mod battery. on the way home, the battery started dying, so i gave it a rest. got home, threw it on the charger, and nothing. charger plug still showing green solid and not changing status. LED still lights up and stays active, but won't activate the atomizer. I've never taken one of these apart before, and im probably just past my warranty. suggestions?
     
  2. DemonCleaner

    DemonCleaner Super Member Verified Member

    Try cleaning all the contacts with alcohol. Isopropyl alcohol. It could just be gunked up. If that doesn't work try pulling the centre post up a smidge with a needle or paperclip.
     
  3. bacc.vap

    bacc.vap Vaping Master Verified Member

    The first thing I would do is verify whether or not the batt is putting out voltage when the buttons pressed. The only sure fire way to do it is with an electrical meter, if you don't have one try another atomizer, see if that activates, if it does it would mean your first atty is at fault. Getting yourself a meter though is key to troubleshooting these things,does'nt have to be an expensive one, well worth the 10 to 20 bucks.

    Another thing you could try that sometimes works on other batteries is to unplug the charger from the socket, then quickly move the prong in and out of the socket three or four times. This is a shot in the dark, but it works with battery drill batts sometimes, who knows. It's like they build a timed obsolescence into things, just make it shut off so you have to buy new.
     
Thread Status:
Not open for further replies.

Share This Page