Weird Flashing C Twist.

Discussion in 'eGo Type Models' started by munsterrr, Aug 28, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. munsterrr

    munsterrr Can't stop, won't stop Verified Member ECF Veteran

    Joined:
    Dec 7, 2009
    Location:
    Washington D.C.
    What I just ordered from discount vapers:

    • 1 x 510 Battery to eGo adapter
    • 1 x E-Liquid - Blackberry
      (Nicotine Level: 18mg, Bottle Size: 15ml)
    • 1 x Medium Case 2
    • 1 x eGo/510 USB Rapid Charger - 420mAh
    • 1 x eGo C Twist 900mah Variable Voltage - Black
    • 2 x Mini Vivi Nova Tank Clearomizer 2.5ml - eGo threaded

    Let the twist charge for 2 hours. Connected the mini vivi clearo to the battery after filling it up and letting it sit for the 2 hours. I screw it on and the light(white) lights up and starts burning the juice before I even press the button. I let it sit for 5 seconds and press the button. Nothing happens at all. Try pressing it 5 times to "unlock" it. Nothing happens. Only way to get a response from the battery is to unscrew it(less than a quarter turn does it) and screw it back and it starts burning again. With or without the 510 adapter, doesnt matter. Same exact results

    Im problably missing something but not sure. Thanks ahead of time


    UPDATING TO ADD VIDEO TO BETTER UNDERSTAND MY GIBBERISH
     
  2. SpringzVz

    SpringzVz Senior Member Verified Member ECF Veteran

    Joined:
    Jul 3, 2012
    Location:
    Colorado Springz, CO
    Try a carto you know that works and see results?
     
  3. munsterrr

    munsterrr Can't stop, won't stop Verified Member ECF Veteran

    Joined:
    Dec 7, 2009
    Location:
    Washington D.C.
    Wish I had one laying around. This is my first start back at vaping after a few years though.
     
  4. skelley

    skelley Super Member ECF Veteran

    Did you try the other clearo?
     
  5. munsterrr

    munsterrr Can't stop, won't stop Verified Member ECF Veteran

    Joined:
    Dec 7, 2009
    Location:
    Washington D.C.
    What's up brother. Yes I did. I'm willing to bet i'm just missing something some where. Is the juice supposed to be touching the top of the battery or no?
     
  6. munsterrr

    munsterrr Can't stop, won't stop Verified Member ECF Veteran

    Joined:
    Dec 7, 2009
    Location:
    Washington D.C.
    UPDATE:

    Let the battery charge all night(so i think) and still nothing.

    QUESTION:
    Is the light/button on the battery supposed to do anything while its charging? The charger shows a green light even with nothing connected(prob just showing that its working). The battery flashes 5 times when connecting it to the charger(wall or USB).

    Adding second video to show the problem better
     
  7. SpringzVz

    SpringzVz Senior Member Verified Member ECF Veteran

    Joined:
    Jul 3, 2012
    Location:
    Colorado Springz, CO
    This looks like a center post issue. The batt is defective. Hopefully you can contact the vendor and resolve this with a new batt. I wouldnt mess with wiggling the center post to see if it pops back up and makes contact as it will just happen again and again if the guts of the batt are defective. Send it back... Sorry this happened bro.
     
  8. SpringzVz

    SpringzVz Senior Member Verified Member ECF Veteran

    Joined:
    Jul 3, 2012
    Location:
    Colorado Springz, CO
    Also for future reference you are overtightening the clearo and charger. You dont want to snug these things down too much as there is a rubber under the center post that can become too compressed and cause contact issues in the future. Just scre it on enough to make contact for the circuit and maybe just a lil more but not tight.
     
  9. YKruss

    YKruss Ultra Member ECF Veteran

    Supporting member
    Joined:
    Apr 21, 2009
    Location:
    Springfield, VA
    Yeah, it looks like you're applying to much force while screwing thus causing the center post to go down and probably smashing the silicon insulator between the center post and the Twist body.

    I would try to pry that center ping out one notch at a time.

    BTW - on your video, when you are uncrewing and find that "right" spot for clearo to fire it is firing for 10 seconds and then Twist is shoting it of cause it has that 10 sec shot of protection.

    Link to "Center Pin Issue - Fixing a non firing eGo battery " - http://www.youtube.com/watch?v=9x95J3ljQ54
     
  10. munsterrr

    munsterrr Can't stop, won't stop Verified Member ECF Veteran

    Joined:
    Dec 7, 2009
    Location:
    Washington D.C.
    Thanks for the advice and input everyone.

    Eric told me to send the old battery back and he will send me a new one. Will keep this thread updated just in case it is the clearos
     
  11. SpringzVz

    SpringzVz Senior Member Verified Member ECF Veteran

    Joined:
    Jul 3, 2012
    Location:
    Colorado Springz, CO
    Please let us know if it turns out to be the clearos as well. Wouldnt want to order a mismatch for my twists:)
     
  12. Charlie58

    Charlie58 Super Member Verified Member ECF Veteran

    Supporting member
    Joined:
    Sep 20, 2009
    Location:
    Florida,U.S.A.
    If it starts to fire as soon as he cart is screwed down and blinks then does the same after unscrewing and screwing back down, it seems the switch is stuck on.
    It will fire until it times out and shuts off, then when you break the connection by unscrewing it it resets.
    The charger lights green because the battery is charged.
     
Thread Status:
Not open for further replies.

Share This Page