The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.
Jake67
Last Activity:
Jul 3, 2019
Joined:
Apr 1, 2014
Messages:
864
Trophy Points:
103
Positive ratings received:
622

Post Ratings

Received: Given:
Like 622 870
Agree 0 0
Disagree 0 0
Funny 0 0
Winner 0 0
Informative 0 0
Love 0 0
Useful 0 0
Optimistic 0 0
Creative 0 0
Location:
Us

Share This Page

Jake67

Super Member, from Us

ECF Veteran
Jake67 was last seen:
Jul 3, 2019
    1. angie124
      angie124
      Hi jake67
      Read your post about mini nautilus. Could you give me some advice. I'm running mine on 4.3-4.5v as you advised in your post it works fine for a while then I start to get a bit of gurgling and start to lose vapour. Sometime I get what feels like a blockage or lose of power in the middle of taking a draw (don't know which). I'm using an Itaste clk 1280 battery. I'm on my second mini as the shop exchanged my first one as I thought there was something wrong with it. Seems to be doing it again now so it must be either my battery or something I'm doing wrong. I was using an evod glass before so easy and reliable but nowhere near as good as the nautilus when it's working. I'm fairly new to vapeing so don't understand to much technical stuff lol. Be grateful for any help. Getting desperate after 3 weeks of problems
      Angie
  • Loading...
  • Loading...
  • About

    Location:
    Us
  • Loading...
  • Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice