The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Brand new EH 18350 1200mah 3.7v batteries not working in my Maxi Rough stack.

Discussion in 'Battery Issues' started by Ouch1234, Jun 15, 2013.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Ouch1234

    Ouch1234 Full Member

    Sep 30, 2011
    Oklahoma
    Just got my batteries from Madvapes today, Soon as I opened them I put them in the charger, after they showed charged I went to use them, but they won't work, Got the voltmeter out and they are fully charged. Any ideas what the problem may be? They are the same size as the ones I've been using for years. Everything looks fine on the batteries, but for both of them not work gives me concerns on how good these batteries are. First time Madvapes ever sent me these EH batteries in replacement of the blue ones or Trustfire I usually get.
     
  2. dangkhoa02106

    dangkhoa02106 Senior Member ECF Veteran

    Mar 11, 2013
    VIET NAM
  3. shawnavonsr

    shawnavonsr Senior Member Verified Member ECF Veteran

    Apr 27, 2013
    Jennings, LA, USA
    I would ask what the resistance of your coil is on that rig? The reason being is your new batteries could be protected and won't work due to the load your asking from them.
    I have had that problem before. Also my seigeli zmax wouldn't work with trustfire batteries for a similar reason.
    It pay to research and buy batteries for the application you need.
    Just my 2 cents
     
  4. 1Pete

    1Pete Full Member Verified Member

    Nov 4, 2012
    Texas
    I don't know if it's the Sigelei stomp (Kick clone) that I'm using, or the EH 18500 batteries from MadVapes, but I'm having similar issues. The batteries show fully charged but won't work longer than about 5 vapes before stopping.
     
  5. dale1962

    dale1962 Ultra Member ECF Veteran

    Oct 24, 2009
    Charlotte,NC
    I just got some EH IMR 18350's 800mAh flat top batts that are so recessed they will not even make contact to fire both of them :(.The cover or sleeve on batts is higher than the positive connection...any fix to these other than sending them back?
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice