The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Digiflavor Pharoah RTA!

Discussion in 'RTA' started by mongo74, Feb 16, 2017.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. BlackCRX

    BlackCRX Senior Member ECF Veteran

    Feb 20, 2014
    Vancouver Canada
    Also if I can add something. Trim the wick so it reaches the bottom of the juice channel and don't do the "v" cut on them either. 3mm ID coil is ideal for me because I feel that 3.5mm ID to be too much cotton for those channels.

    I don't chain vape or vape at high wattage. I have a 3mm ID dual 26 core with 36 wrap, ohms at 0.25ohms, 50-60 watts but temp controlled at 450F. Never had an issue with wicking as of yet. Also I leave the JFC wide open at night with 60vg juice and no signs of leaks in the morning.
     
    • Like Like x 1
  2. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    You also don't have the gold one. As far as i can tell only 2 people have the gold one (me being one of them) and both have the same issue

    Just like the exo thread, a few people had issues with jumping resistance. I didn't claim they were doing it wrong and then question their knowledge. Instead after several discussion we found out there was a bad batch of black exo RTAs. hasn't had an issue since. There could very well be an issue specific to the gold version hence the reason I just ordered a black one as well. The issue is if everyone had your "holier then thou" attitude, nothing would ever get solved.
     
    • Like Like x 1
  3. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    Been there. i wicked it 8 different ways with the normal deck and 4 with the dual coil postless deck. never found a good balance. i'm leaning towards mine is defective or the gold one's have issues. I'll know more when the black one arrives next week i just ordered
     
  4. BlackCRX

    BlackCRX Senior Member ECF Veteran

    Feb 20, 2014
    Vancouver Canada
    Does it leak while over night when you wick it the "dry hit city" method?

    I'm asking because if it does leak, you might have a bad O ring. If it doesn't, changes are the O rings are fine as it is holding vacuum in the tank. Hope that makes sense.
     
  5. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    I don't remember it leaking really but that was like a month ago. I've washed the tank several times over. changed all the orings, used all the spare sets and still nothing. I spent way too much time getting this to wick right and not leak. and i pretty much nail every RTA i get the 1st time lol.
     
  6. BlackCRX

    BlackCRX Senior Member ECF Veteran

    Feb 20, 2014
    Vancouver Canada
    Not sure if this has been asked or mentioned before. When you have your tank fully assembled on a mod, wiggle the top of the tank by holding the drip tip. Does it wiggle?
    When I disassembled my clone base to sand it down. I noticed that there is an o ring between the black AFC base and the silver base that the chimney/tank screws on to.
    If that O ring is bad you might get some seeping or leaking from the AFC. It could seep down between the removable deck and the silver base that the chimney screws down too.
     
    • Like Like x 1
  7. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    I'll give that a try tonight

    Sent from my SM-G935V using Tapatalk
     
  8. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    Yup it wiggles between the bottom part and the AFC and I can see juice in it

    Sent from my SM-G935V using Tapatalk
     
    • Like Like x 1
  9. BlackCRX

    BlackCRX Senior Member ECF Veteran

    Feb 20, 2014
    Vancouver Canada
    Might want to disassemble it and give the base a love tap or a squeeze and see if that helps.
     
    • Like Like x 1
  10. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    Yup that's the next step

    Sent from my SM-G935V using Tapatalk
     
  11. Gallant

    Gallant Super Member ECF Veteran

    Dec 4, 2013
    Edmonton, AB, Canada
    That might explain it I have the black1 no issues at all
     
  12. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    Yup. after this convo with everyone i ordered a black yesterday. it already shipped. i shold have it monday or tuesday next week
     
    • Like Like x 1
  13. Gallant

    Gallant Super Member ECF Veteran

    Dec 4, 2013
    Edmonton, AB, Canada
    Keep us updated!
     
    • Like Like x 1
  14. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    Will do!
     
  15. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    So update. black one arrived yesterday. Wicked it normally (like my video but without the angle cut) no leaks and wicking good enough for no dry hits. Seems like the vaporlock and leak issues was caused by a manufacturing defect. So i'll need to make an update video and i'll see if i can fix the gold one. If i can i'll make a video on how to. If not i can try and warranty it i guess lol. Doubt it'll get me anywhere though
     
    • Like Like x 1
  16. Tintreach

    Tintreach Super Member Verified Member ECF Veteran

    That's awesome for the exception of having to buy a 2nd one because the first didn't work. Now you got good parts to start swapping and see where the issue is
     
    • Like Like x 3
  17. Anthony_Vapes

    Anthony_Vapes Ultra Member Verified Member ECF Veteran

    Jan 23, 2017
    .... happens lol. I buy a lot of stuff and with china QC it's bound to happen. I've had a few duds on my for sure this year. last year i was pretty lucky. only 2 mods with issues and both taken care of quickly (funny enough 1 of my 8 hohmtech mods and 1 of my then 5 DNA mods) none of my cheap china mods gave me any issues last year. this year has been quite a few. I'm just glad i have one that doesn't leak now and wicks great because i really love the build deck and flavor on it. It's in consideration for my top 5 RTA list now when I update it. I also got 2 more new tanks yesterday (green kylin rta and matte gun metal supreme v2) so far they are contenders as well. i'll probably do my update in july so i'll know for sure by then. It's going to be tough as hell to pick 5 lol
     
    • Like Like x 2
  18. Steamer861

    Steamer861 Ultra Member Verified Member ECF Veteran

    Jan 13, 2014
    Canada
    So My Pharaoh that the press fit threads came loose on, & had to be pressed back in, is now not reading the resistance consistently :(
    This sucks cause every once & awhile my residence goes out of wack:(
    It jumps up about .06 & I get Temp protection warning on my screen!
    If I unscrew it & screw it back the resistance goes from .14 to .20 :(
    If I except the new too high resistance it will burn my cotton.
    It's obvious to me the loose press fit threads aren't making a perfect ground all the time.

    If Digiflavor is reading this, Please make available a replacement base! So I don't have to buy a whole new Pharaoh! Thanks
     
    • Like Like x 1
  19. Eskie

    Eskie ECF Guru Verified Member ECF Veteran

    May 6, 2016
    NY
    You're talking about the actual base, not the decks? Maybe Digiflavor will replace it if you contact them and explain the press fit failed. Never hurts to ask.
     
    • Like Like x 3
  20. Steamer861

    Steamer861 Ultra Member Verified Member ECF Veteran

    Jan 13, 2014
    Canada
    I tried to post a message on their site yesterday & it wouldn't work:( Maybe I will try again.
    Yes just the base, The contact between the threads & the base (press fitted together) Is now a weakness in the - connection :( The DNA always finds a weakness in the connection :(
    For TC to work Good! there needs to be a solid + & - connection thru from the 510 all the way to the coil :)
    But you all ready knew that :)
     
    • Like Like x 2
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice