The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

[DIY Story] My Evic Vtwo Mini Repair Story

Discussion in 'APV and Mods Discussion' started by flexy123, Feb 2, 2018.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. flexy123

    flexy123 Senior Member ECF Veteran

    Mar 29, 2009
    This is just a story I feel like sharing.

    I have an old Evic Vtwo Mini which I like a lot. It does anything for me I like, the size and the feeling in my hands etc. I am a MTL low wattage vaper, currently at 11.5W only and with an even older Kayfun 2.1.

    Anyway, the VTWO's micro USB port started to make troubles and got sorta loose not long after I got it, unlike my wife's which doesn't have any problem. For some time, it was fine but finicky....but at some point the USB port was hosed.

    Since I am 90% of my time spending with "fixing things" and I am not new when it comes to using a soldering iron, I removed the broken USB port entirely...and made a ghetto connection soldering wires directly on the PCB inside the mod...so I can connect it to USB and vape.

    (I am having my vape always connected to USB since I only vape on the PC, eg. for work etc.)

    The ghetto wiring without a proper micro USB port worked for a month or so.

    At some point, and I have no idea why (because I am certain that I connected everything right, it was just the two wires for charging, +5 and GND), the device started to show signs that the battery is going. It started to behave strange, the battery I had in there (LG HE2) only charged up to like 10%, and then I had like maybe 10 puffs and I got low battery warning and the thing stopped. Then I had to wait again for it to get some charge, rinse and repeat. I was convinced that the battery is dead.

    So a week ago I ordered a Nitecore and two Samsung 25Rs so I can properly vape again. This is still in the mail tho.

    Today I got replacement solder micro USB ports. Because I wanted to change back my Evic so it has a proper port etc., I removed my ghetto wiring and soldered in the new USB port. (Don't ask, it was an incredible pain in the ... . Reason being that my soldering iron sucks, I was also unable to properly de-solder using desoldering wick. Because of that, the entire procedure took me MUCH longer than it should have. It's just a fricking micro USB port. That everything is microscopic small and you only see what you do with a loupe..doesn't make things easier...

    After I finally soldered the port in and it looked "somewhat ok" after checking everything with the loupe, I put together the Vtwo just to see whether everything would EXPL...I mean work.

    Low and behold, it did! I put it together, put back the "bad" battery, and would you believe it, now the device charges like new again and doesn't show the odd behaviour it had before. Now even the battery is charging alright, the battery I thought was pretty much toast because it could barely hold any charge!

    I am surprised because I did a really AWFUL soldering job and TBH didn't even expect it to work on the port. I was also surprised that not only the charging worked again, but the other pins of the USB are fine too (despite the worst soldering job in history), so I could even do a firmware update and now have the latest firmware with the preheat as well. (Not sure about the preheat tho, vape gets almost too hot for my taste, even at 17W preheat at 0.3sec...but nice to have!)

    ** In case you're wondering why to go through all this: Money is tight right now and €40 for a vaporizer would just suck. Yes there are Chinese vendors who sell the Vtwo cheap, like €19, but then it usually takes a month to get it. I am just so happy that I have a working vape again!!! (I also had a spare old Istick 30W which would be "fully ok" otherwise, but this also has a dead battery and stopped working the same time when the Evic stopped working right)

    PS: Not sure why the Evic now works "like new again", I really don't think it was the wiring because this was straight forward and also worked for a while. I think what fixed it is actually that I removed the battery to fix the port (which I couldn't before because of the wires) and I guess this reset the device.

    **** Mandatory disclaimer: Of course soldering and ghetto rigging a vape with a 18650 battery is potentially dangerous !! So I don't recommend this at all unless you really know what you're doing!! ****

    I just wanted to share my happiness that I have a working vape again, and it just cost me 90% of my nerves and €3 for 5x micro USB replacement ports! (The right ones, by the way, are not easy to find on ebay, but a couple vendors carry them)

    Edit: I am hoping the micro USB port stays in now, this is really a weakness of many vapes, IMO. I know that many recommend not even to use over USB and use a proper charger instead, but I just like the convenience.
     
    • Winner Winner x 1

Share This Page