The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.
  1. Hi Guest! 

    Seasons Greetings. Just to let you know that a new giveaway has just started. 

    This one's from our friends at Humble Vape Co. and I hope you'll take part for a chance to be one of the ten winners of their great prizes. 


    See our giveaway page for full details. This one's for US residents only. 

    Good luck! 


    Dismiss Notice

Ego battery wont fire after charging

Discussion in 'eGo Type Models' started by withravenoushunger, Mar 29, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. withravenoushunger

    withravenoushunger Super Member Verified Member ECF Veteran

    I just got 2 Ego batteries and 2 Evods today. They were working great for a while but after I charged them, they stopped firing. After taking them off the charger, the battery would work fine. The buttons would light up and go in and out of sleep. But when I attached my Evod, it stopped working. The light would flash once and not work at all. It's doing this for both batteries and evods. It seems like it's shorting but I dont see why it would. I believe they are 1.8 and 2.2. The batteries I have now are Ego C. My older ego works fine with them. I am also getting a chemical like taste from them too.
  2. williebb123

    williebb123 Ultra Member ECF Veteran

    check your batts with a voltage meter see if any voltage at all is coming out at the end , my sister just sent me a brand new ego c that did not work the button lit up so i checked it had 1.3v coming out the problem was the ground solder joint came loose so all i did was resolder and now it works like a champ . if you do have to take it apart its very easy the top pulls straight out with alittle side to side wiggle and a pair of pliers wraped with cloth to keep any scarring to a min.
  3. withravenoushunger

    withravenoushunger Super Member Verified Member ECF Veteran

    I don't have anything to test the voltage. But for some reason it seems to work randomly. They were being difficult all night, but seem fine right now.
  4. Unforeseen

    Unforeseen Asst. Suppliers Manager Admin Verified Member ECF Veteran

    Supporting member
    Moved to Model Specific Discussion - ego Type Models
  5. withravenoushunger

    withravenoushunger Super Member Verified Member ECF Veteran

    They are still working on and off. I dont have any means to solder it. I do think it's weird that it does the same thing on both batteries. Could it be the attys?
  6. Rin13

    Rin13 Ultra Member Verified Member ECF Veteran

    Dec 9, 2011
    To me, it sounds like the atty's. The only time my egos do that is when the atty is bad/has a short. The blue light will flash and it won't fire.
    Maybe the old battery doesn't have an anti-shortage feature, which is why it works. Just a guess
  7. ElConquistador

    ElConquistador Ultra Member ECF Veteran

    Mar 24, 2013
    I have that problem every once in a while. It seems the positive contact on the battery gets "mashed down" just a hair and fails to make a good connection with your atomizer. I keep a tiny little screwdriver (from an eye glasses repair kit) in my kit. If you very, very, very carefully work it around the edges of the little contact disk in the end of the battery and ever so slightly pry up on it, just a tiny little bit, it'll correct the bad connection. ****be sure to turn the battery OFF first, I assume it would short out otherwise****.

    Be very gentle, you just need to pull it up a hair. It's worked every time for me. I read this little trick somewhere on this board a while back before I ever had the problem and remembered it so was prepared when it happened to me.

    Did I mention to be very careful, gentle, and just barely pull it up a tiny little bit?
  8. withravenoushunger

    withravenoushunger Super Member Verified Member ECF Veteran

    Moving the pin up seems to have helped. I just dont see why they designed it like that. Thanks
  9. Lessifer

    Lessifer Vaping Master Verified Member ECF Veteran

    I have two different ego batteries from two different vendors and when I put them side by side I can see that the ego threading on one battery is lower(<1mm) than on the other one, which causes the center pin to get pushed down just enough so it won't make contact with my charger whenever I put a T3 on that battery. It's annoying.
  10. mathematicus

    mathematicus Full Member Verified Member

    Mar 14, 2013
    my bet is the ground solder joint, you can pull the tube out of the battery and check it. however, if you don't solder, then that may not do you any good. electrical tape may work in a pinch. i work at our local shop, and we can fix them if people bring them in. so, if you have a local shop, let them look at it.
Thread Status:
Not open for further replies.

Share This Page