The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Evic Primo Mini ohm readings consistently off by .1 ohm

Discussion in 'Temperature Control' started by Beamslider, Feb 5, 2018.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Beamslider

    Beamslider Ultra Member Verified Member

    May 29, 2017
    San Francisco
    I have an Evic Primo mini. The ohm readings compared to all other mods and ohm meter that I have are off by .1 ohm. It consistently reads .45 ohm coils as .55 ohm compared to other mods.

    Used this mod for about 4 weeks and it didn't used to read wrong by anything like this amount. I have cleaned all contacts even though they seemed to be clean already.

    I was using it in TC mod before it started misreading by this amount. Obviously not working in TC mod anymore with that much off on the reading.

    Is there any way to calibrate this mod? Or should I just write it off as unusable?
     
    • Like Like x 2
  2. Eskie

    Eskie ECF Guru Verified Member ECF Veteran

    May 6, 2016
    NY
    If the offset is consistent it's something you could just live with, just not rely upon to determine resistance when building. As to the TC issue, yeah, that's shot so if you're primarily a TC user it's toast. But in wattage mode it shouldn't matter and simply be used as a beater for however long it continues to last.
     
    • Like Like x 3
    • Agree Agree x 2
  3. maibol

    maibol Full Member

    Oct 24, 2017
    Have you considered to try artic fox ?......since i try it my joyetech mod works amazing and they are more accurate on TC
     
    • Useful Useful x 2
  4. Beamslider

    Beamslider Ultra Member Verified Member

    May 29, 2017
    San Francisco
    same still reads off. Just wrote it off. No way to fix it.
     
    • Like Like x 1
    • Optimistic Optimistic x 1
  5. maibol

    maibol Full Member

    Oct 24, 2017
    that's sucks it is a small difference but it messes badly with TC what kind of wire do you use?

    Sent from my X522 using Tapatalk
     
    • Agree Agree x 1
  6. Beamslider

    Beamslider Ultra Member Verified Member

    May 29, 2017
    San Francisco
    SS but no problem I have some other mods including some DNA ones.
     
    • Like Like x 1
  7. Hex nut

    Hex nut Full Member

    Feb 6, 2018
    Netherlands
    @Beamslider, sorry to hear your Primo Mini is having such serious issues. Mine's still working pretty decently for the past eight months or so. There is a new firmware update, maybe that's worth trying? Software download - Joyetech
    Doesn't appear to be a complete overhaul, although TC seems a little smoother - at least on my MTL atties. Can't say if it's the same on more exotic coils, because I'm only using simple ("boring"?) spaced coils.
     
    • Useful Useful x 1

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice