Evod on a Vamo, use an adapter?

Status
Not open for further replies.

Litta'sGabby

Super Member
ECF Veteran
Verified Member
Apr 24, 2013
378
677
Sandston, Virginia, United States
    When I purchased my Vamo, the store manager tested my Evod on the store testing unit. At first it didn't fire, so he used an adapter and it fired fine. I had misplaced my adapter and tried the Evod on my Vamo without the adapter and it fired just fine. I also had trouble with this Evod on an eGo unit and blamed the unit. Now, I think I have a bad Evod. So for those who use an Evod on your Vamo, do you use an adapter? Would also love your recommendations on where to buy Evods. I am looking for a new vendor. Thanks!
     

    Litta'sGabby

    Super Member
    ECF Veteran
    Verified Member
    Apr 24, 2013
    378
    677
    Sandston, Virginia, United States
      Thank you everyone! Coming off of an eGo without any VV/VW I was shocked at the difference in the taste of my juice. I used my eGo at work today with my Evod, and it's terrible! Hot juice! ewwww! How did I Vape that?? Anyway, I am finding that using the adapter is better on the Vamo, at least until I can get a couple more Evods. I love the Pro Tank on my Vamo the most, though!
       

      VapRLady

      Senior Member
      ECF Veteran
        Your atomizer may not be screwed in tightly enough to the base make a connection, not on the battery mind you, the base of the tank itself. Open it up and crank down on it. Check your atty tightness everytime you refill, it can loosen when unscrewing.

        Never overtighten kanger products on your battery, just finger tight.

        Also, overtightening an eVod on any battery will cause the atty to twist like a pretzel and give a serious burned taste.

        Easy goes it.

        sun-vapers probably has the cheapest price and delivery is usually 3-4 days. Shoot... I just checked the site, they are out of stock right now,,,
         
        Last edited:

        Tommy Aces

        Senior Member
        ECF Veteran
        Verified Member
        Jan 28, 2013
        287
        327
        Connecticut
          OP - Yes, the eVod should work just fine on the VAMO with no adapter. Just be careful not to unscrew the tank portion instead of the base when you unscrew the device.

          As for the one you have that doesn't work, it may be the center post on that eVod base isn't making contact. What you can do is take a pair of tweezers, grab the center pin in the base of the eVod, and just pull it down a tiny bit. Then just try and avoid over tightening when you put it on the VAMO and see if it fires.
           
          Status
          Not open for further replies.

          Users who are viewing this thread

            ')