The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

KR808-D1 batteries (vapor king)

Discussion in 'Battery Issues' started by TheBulla, Oct 6, 2010.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. TheBulla

    TheBulla Full Member

    Jun 18, 2010
    Monmouth, IL USA
    I'm having problems with 2 of my VK batteries, the same issue plagues both. Both are clean as a whistle, I've scraped them out with a thumbtack and even applied some rubbing alcohol on a q-tip to clean the threads and the inside of the battery. The problem is they don't seem to be making contact with either my chargers or my cartomizers. If I pull on just the batteries, they light up just fine, but as I said I get no vapor out of them, and I can't seem to charge them any further. Anyone have a possible solution or am I just SOL?
  2. TheBulla

    TheBulla Full Member

    Jun 18, 2010
    Monmouth, IL USA
    Nobody has any solutions?
  3. taylormomto6

    taylormomto6 Full Member

    Sep 15, 2010
    I don't have any solutions, but I've also had the same problem. I sent 2 back over a week ago, but I haven't heard a thing from them since. They were only a couple of weeks old.

    Cindy T
  4. mlady

    mlady Senior Member ECF Veteran

    Nov 24, 2008
    i have the exact same problem.
    i have batteries, that simply don't work.
    i only have ONE battery that works at this moment in time.
    kind of hard to be a dedicated e smoker, if i don't have the parts.
  5. taylormomto6

    taylormomto6 Full Member

    Sep 15, 2010
    I'm in the same position. I've ordered a couple more, but I don't want to keep buying new batteries twice a month.

    My manual is better, but still acts up sometimes.

    Cindy T
  6. KILLERkpd

    KILLERkpd Senior Member ECF Veteran

    Oct 5, 2010
    East Coast
    Are the batteries not taking a charge? Are they blinking when you screw them into the charger?? I had an issues with my batts, one would charge after I messed around with it for about 15 minutes, and the other batt would not do anything.

    What I eneded up doing is taking the screw out of the USB part only, very gently screwing the batt back in and trying to charge that way, it worked perfectly, I then just screweed teh cover back on that I had removed. There were a few times that I had to repeat this process but it worked.
  7. StormFinch

    StormFinch Ultra Member Verified Member ECF Veteran

    Mar 22, 2010
    You might try running a piece of fine sand paper or an emery board lightly over the thread sides and top. They did have some problems with burring at one time and the batteries weren't making proper connection. If that doesn't work I'd contact them for return and ask them to test anything they send out as replacement.
  8. taylormomto6

    taylormomto6 Full Member

    Sep 15, 2010
    I have one that is just dead, no blinking, no nothing and one that will work for a drag or 2 if I tap it on the counter or get something sharp and lift from the little hole where the cartomizer connects. This one is clearly not getting a good connection.I've already sent one back, this is the replacement. It worked great for a few days before it starting acting up. The 2 I sent back to VK are apparently not going to be replaced.Cindy T
  9. Mavrickk

    Mavrickk Senior Member ECF Veteran

    Sep 28, 2010
    Norwalk OH
    try pulling up on the center post in the battery, sometimes that can get pushed down so it won't make connection, have to do that on one of my batts every couple days.
  10. Goldenkobold

    Goldenkobold Ultra Member ECF Veteran

    Oct 23, 2010
    thanks for this, my (only) battery was acting funny and only charging for a few seconds before showing as charged....this seems to have fixed the problem
  11. Goldenkobold

    Goldenkobold Ultra Member ECF Veteran

    Oct 23, 2010
    well my battery just died completely....
    no blinking on the charger but if I inhale (without a carto) the led still turns is just not heating up the atty in the carto..
    any suggestions?

    I did just find out that smoketip has a lifetime warranty on these I guess there is always that
  12. BillyP

    BillyP Senior Member ECF Veteran

    Oct 20, 2010
  13. mnegrete1

    mnegrete1 Senior Member ECF Veteran

    Jan 17, 2011
    I had the same problem and I found out that if you just flick the battery while your pulling a drag it works.
  14. SmokingBullet

    SmokingBullet Super Member Verified Member ECF Veteran

    Nov 17, 2010
    Southern Utal
    The first PT I had from V4L, just up and stopped working on day, about 38 to 40's into it. The replaced that on. The 2nd one I had which I ordered; also a PT, is now 30 days old. The button sticks and won't come back up which I'd think can be hazardous.
    Reading these threads, I'd think V4L would work on improving battery life rather than worrying about how pretty they look.
  15. TheLexicana

    TheLexicana Senior Member ECF Veteran

    Dec 16, 2010
    Cincinnati, OH
    Seconding the part about pulling up the center post on the battery. As long as the carto is screwing all the way down, this will almost definitely fix your problem. Just take something narrow (a thumbtack, or pointy tweezers), poke it into the hole in the battery post (if it's an auto) or into the well around the center post (if it's a manual), and wiggle it up just a little.
  16. marine13

    marine13 Full Member

    Jan 23, 2011
    Austin Tx
    ya guys it is more than likely the center post most common problem is you screwed it in the charger too tight or the cart. Fix it bu pulling the center part up and then just screw in to whatever it is tell it works. If you are screwing in to a cart watch the hole on the ring you want to turn it to about the 2nd to the last hole.
  17. Dustyrider99

    Dustyrider99 Full Member

    Jan 5, 2011
    I just received three new replacement batts from Smoketip. LIFETIME REPLACEMENT on Smoketip batteries no questions asked. I used these three heavy for two months before they would not take charge. Placed them in mail and had new in three days. With markup on these batteries why can more companies give real warranties?
  18. TheBulla

    TheBulla Full Member

    Jun 18, 2010
    Monmouth, IL USA
    I know this is an old post, and sorry for trudging it up, but I thought I had solved the problem when I was noticing one of my batteries was only working with certain cartos, and I came up with the center post fix all on my own, however it hasn't fixed the original batteries I had. They still won't charge or vape, but they light up when you drag on them. They're way out of warranty now though.
Thread Status:
Not open for further replies.

Share This Page