M702 PCC/Batt Help...please!

Status
Not open for further replies.

halonut

Unregistered Supplier
ECF Veteran
    Hello

    I just got the M702 today and it worked great for 4 battery charges but now the PCC (which is fully charged) will not charge, or apparently even recognize the battery in the PCC! (whether the PCC is plugged in by USB or unplugged).

    Now when the batt is screwed in and the button depressed the LED on the case flashes normally but the LED at the end of the batt does not flash & after the the case LED is done flashing it does not show either red or green to indicate battery condition. Worst of all the batt's (came with 2 of them) are not being charged at all.

    I read about the soft & hard reset procedures and tried them but they aren't working. I do not believe that the contact in the PCC is making a proper connection to the batt's and the PCC doesn't even recognize that there is a batt in the charging slot.

    I definitely could be wrong though, anybody have any ideas or sugg's before I send this thing back?

    Thanks!

    ps: This is my first e-cig & it was alot of fun for the few hours it worked!
     
    Status
    Not open for further replies.

    Users who are viewing this thread

      ')