The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Proud new owner of a Provari, have a question.

Discussion in 'ProVape' started by Master Rawl, May 30, 2011.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Master Rawl

    Master Rawl Full Member Verified Member

    Hello fellow Provari owners,
    I just recieved mine Friday and it has been working great all weekend. Though starting today I've been having a small issue. When I replaced the IMR 18650 battery, the device would not turn on. The button light would sort of fade on and off and the display would not turn on. After taking the battery out and replacing it a few times, it started working again perfectly. Interestingly, there were no error codes. I just wanted to ask if anyone else has had this issue and if it's something that will get worse. Thanks for any advice.
     
  2. asidrave

    asidrave Ultra Member Verified Member ECF Veteran

    Feb 21, 2009
    New Jersey
    hmmm...only thing i could suggest is to make sure the contacts on your battery and provari are clean. If they are clean...i have no clue
     
  3. ScottinSoCal

    ScottinSoCal Ultra Member ECF Veteran

    Dec 19, 2010
    ProVari Nirvana
    Mine has done something like that a couple of times, but it's been when I mistakenly put a drained battery in, instead of a charged battery. It wouldn't fire and when I hit the buttons to get the display (to check the atty and battery) it wouldn't display anything.

    I'm going to back up the suggestion above - check the contacts. Maybe there's something on them that was keeping you from getting a good, solid connection for power flow.
     
  4. Master Rawl

    Master Rawl Full Member Verified Member

    Thanks for the tips. I've cleaned the contacts and so far so good. I was using a Ultrafire 18650 before I put the AW back in. As I did that, I noticed the Ultrafire is a little longer than the AW. That made me worry that maybe I pushed the contact up a tad with the longer battery. After looking inside I realized that shouldn't happen, being that the build quality in there looks tough enough to handle a bit of pressure. I hope it was just some left over particles on the positive contact from the manufacturing process.
     
  5. ScottinSoCal

    ScottinSoCal Ultra Member ECF Veteran

    Dec 19, 2010
    ProVari Nirvana
    You'll get weirdness with other batteries. They don't put out power as fast as the ProVari needs, and it trips the protection circuit on the PV. I've always stuck with the recommended batteries.
     
  6. asidrave

    asidrave Ultra Member Verified Member ECF Veteran

    Feb 21, 2009
    New Jersey
    The trustfire that works for me is the TR 2400mah. i had 4 of them and they worked in the provari no problems. on the battery it does say "high discharge rate". The Trustfire TR and AW's both work vey well in the Provari....The Trustfire has a small 1mm gap when in the Provari because the battery is slightly longer.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice