The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Therion DNA 75C BF 510 connector problem

Discussion in 'Temperature Control' started by tokarev, Feb 19, 2018.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. tokarev

    tokarev Senior Member ECF Veteran

    Jan 25, 2009
    Tennessee, USA
    Has anyone else had a problem with some atomizers not making connection on this mod? I just received my Therion BF and 2 of the 4 attys I tried on it do not make a connection with the spring loaded 510 positive. I checked the spring action and it seems to be working fine (not stuck).

    One of my Nardas (all FT clones, BTW) doesn't make connection (shows "no atomizer" error) while another Narda works fine. I also tried a Speed Revolution clone which works but only w/o the beauty ring. The beauty ring only adds about 1mm or so but it seems that is enough to keep it from connecting.

    It seems to me the 510 connector on the Therion is deeper than on my other mods. All of my attys work fine on my VT Inbox which also has a spring loaded connector.

    I do have attys that work on the Therion so it's usable for me but I just wondered if anyone else had encountered this issue.
     
    • Informative Informative x 1
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice