Issue with Apollo eGo 1200mah VV Battery - Need Help

Discussion in 'Apollo Ecigs' started by Aphex_Twin, Jun 25, 2013.

Thread Status:
Not open for further replies.
  1. Aphex_Twin

    Aphex_Twin Full Member Verified Member

    Supporting member
    Also posted within the Battery Forum but hoping someone here might have insight:
    Does anyone have a recommendation on the eGo 1200mah VV battery from Apollo? I reached out to their customer service this morning but I received the unit yesterday and it wouldn't power up. I figured mailing regulations down allow them to ship charged. I charged it overnight with the pass through as stated in the instructions, but even this morning when I tried it, the second I unplugged it from the cable, it died. I thought maybe it was locked as per the operation of a number of other ego batteries. Clicked the power button 5 times within 3 seconds and nothing. I've tried it with and without the tank on it. I tried using it while plugged into the pass through, but it wont produce a charge at all. Does it sound like a DOA or does anyone else have a recommendation at this point other than request a replacement?
     
  2. IronHorse

    IronHorse Registered Supplier ECF Veteran

    Aphex...I have replied to your PM regarding this...:vapor:
     
  3. IronHorse

    IronHorse Registered Supplier ECF Veteran

    It sounds like it might be defective...which occasionally can happen but rarely in my experience with Apollo. Hit them up on the Live Chat Customer Service on the website and they'll get that straightened out for you. E cigs | Electronic cigarettes | Apollo Electronic cigarettes
     
: apollo
Thread Status:
Not open for further replies.

Share This Page