The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Aegis Solo question

Discussion in 'Geekvape' started by Big Orange, Sep 10, 2019.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Big Orange

    Big Orange Full Member

    Jul 7, 2019
    Anyone experience any issues with the Aegis Solo? I just got one today and it randomly shuts down when I’m adjusting the wattage (up or down). Not every time I try to adjust it, but about 3 times now. The highest temp I had it at was 50w. The battery is new and fully charged. Been vaping about 2.5 months, so newish to vaping, but not brand new. Need some guidance from people with more experience.

    Edit: it was a defective mod. The guys at the shop replaced it with no hassle.
     
    • Optimistic Optimistic x 2
  2. englishmick

    englishmick Vaping Master Verified Member ECF Veteran

    Supporting member
    Sep 25, 2014
    Naptown, Indiana
    Never had that happen, and I can't think of anything you could have done that would cause it.

    Did you have a tank on it while you were doing the adjustments?
     
    • Like Like x 2
  3. r77r7r

    r77r7r ECF Guru ECF Veteran

    Feb 15, 2011
    Pa,LandOfTaxes
    Great that you tested it right away. Hopefully you bought it at a place with good customer service.
     
    • Agree Agree x 2
    • Like Like x 1
  4. Baditude

    Baditude ECF Guru ECF Veteran

    Apr 8, 2012
    Ridgeway, Ohio
    What specific battery are you using? Make and model? Not all batteries are equal in specification or performance rating. 50 watts might be too much of a drain for a 15 amp battery. You may need a 20 or 25 amp battery.
     
    • Agree Agree x 2
  5. Big Orange

    Big Orange Full Member

    Jul 7, 2019
    I did.

    I have an Aegis legend and 2 drag minis and I’ve never had this happen with any of those. Picked up the Solo because I’ve read so many good things about them. Might have gotten a lemon
     
    • Like Like x 1
    • Agree Agree x 1
  6. Big Orange

    Big Orange Full Member

    Jul 7, 2019
    It’s an LG battery - 20amp. Picked it up at a local shop along with the Solo. The shop is reputable and the guys will make it right if I got a lemon. Will definitely be paying them a visit today.
     
    • Like Like x 2
    • Optimistic Optimistic x 2
  7. Big Orange

    Big Orange Full Member

    Jul 7, 2019
    I did. I’m going to take it in and see if they can figure out what is going on with it.
     
    • Like Like x 1
    • Agree Agree x 1
    • Winner Winner x 1
  8. bigbob2322

    bigbob2322 Vaping Master Verified Member ECF Veteran

    Jul 27, 2014
    Schiller PK IL USA
    I never had that happen on the 2 I have, hope you get it sorted out.
     
    • Like Like x 1
  9. Big Orange

    Big Orange Full Member

    Jul 7, 2019
    It was the mod. It happens. The guys at the shop were apologetic and gave me another one. No issues with the new one and I love it!
     
    • Winner Winner x 2
    • Like Like x 1
  10. bigbob2322

    bigbob2322 Vaping Master Verified Member ECF Veteran

    Jul 27, 2014
    Schiller PK IL USA
    Great for you!!!
     
    • Agree Agree x 1

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice