The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Boge 510 Cartomizers Help

Discussion in 'Cartomizer Issues' started by luciachan, May 26, 2011.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. luciachan

    luciachan Senior Member ECF Veteran

    Feb 14, 2011
    Toronto, ON
    I just purchased a 5 pack of Boge 510 Cartos after using Joyetech 510 Cartos. I loved the Joye Cartos but my supplier was out of stock. I've been having trouble vaping off the Boge cartos it feels like I'm sucking air with minimal vapor and almost no taste. I thought they were flooded and blew them out, that didn't work. I also thought maybe my ejuice hadn't steeped enough because it was brand new as well, so I filled one of my old Joye cartos and it tasted great with lots of vapor :vapor: also my drip tip is working great. I've tried the cartos on my Mega 510 Manual battery and Regular auto battery with no changes in performance, and I've tried all 5 cartos they're all the same. Is their something I'm missing or doing wrong? Is their some kind of break in routine I should have done?:confused:
     
  2. hairball

    hairball ECF Guru Verified Member ECF Veteran

    Sep 17, 2010
    Other Places
    Unfortunately, you got used to the Joye carto's. I'm a huge Boge fan. I've never encountered a "break in" period needed with these. Some people don't like boge and others love them. Just a matter of preference or in your case, you got used to using another brand.
     
  3. Katya

    Katya ECF Guru Verified Member ECF Veteran

    Supporting member
    Feb 23, 2010
    SoCal
    What is your cartos' resistance, do you happen to know? If it's standard 3.0Ω, they woon't vape warm enough on your 510 batteries. The Joye cartos are 2.5Ω. I suggest you buy 2.5Ω 510 Boge cartos.
     
  4. luciachan

    luciachan Senior Member ECF Veteran

    Feb 14, 2011
    Toronto, ON
    The supplier doesn't list the ohms but on the Boge package it says R-2.8-3 so that must be it. I'll make sure to check ohms before my next purchase. Also what kind of battery would I need to vape warm enough?
     
  5. Katya

    Katya ECF Guru Verified Member ECF Veteran

    Supporting member
    Feb 23, 2010
    SoCal
    Yup, you got the 3.0Ω ones. Useless on 3.1v. IMO. You need at least a 3.7v battery to get something out of the 3.0Ω. Like the new SE Rivas, which deliver true 3.7v under load.
     
  6. Higbe33

    Higbe33 Super Member ECF Veteran

    Mar 8, 2011
    San Diego, CA
  7. Alžběta Madragana

    Alžběta Madragana Super Member ECF Veteran

    Mar 4, 2011
    Cresson, Texas
    Quite possibly you just got a SUCKY batch - I got a few 5-packs of 510s too and they either don't produce much vapour, or the few that did, have BURNED within a few hours.
    It galls me when I get a suck-... batch of cartos!
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice