The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

DNA 250 Lipo

Discussion in 'Batteries and Chargers' started by jojaws, Feb 12, 2018.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. jojaws

    jojaws Full Member

    Feb 12, 2018
    Hi,

    I have trouble with my Flawless DNA 250 1200 Mah 3 Cell Lipo Batter.

    i am at 0 %, and the USB charge don't work.

    I have downloaded Escribe, in the monitoring :

    upload_2018-2-12_21-48-55.png

    Is my Lipo a dead Lipo ?!
    Only 1 month :-/

    If you have ab idea ?

    Thx
     
  2. r77r7r

    r77r7r ECF Guru ECF Veteran

    Feb 15, 2011
    Pa,LandOfTaxes
    Is the battery not working, or, is Escribe telling you that it's not?

    So, the battery is dead?

    I'd contact the supplier, should be under warranty???
     
  3. jojaws

    jojaws Full Member

    Feb 12, 2018
    is this info ? charge ? if not Where can i check that in Escribe?
    upload_2018-2-12_22-19-56.png

    Yes, it's Under warranty :)
     
  4. r77r7r

    r77r7r ECF Guru ECF Veteran

    Feb 15, 2011
    Pa,LandOfTaxes
    Clean out the USB port well? New cable or charger?
     
  5. jojaws

    jojaws Full Member

    Feb 12, 2018
    No, it's the same cable or charger. But tried with different for the same result :-(

    It s the first time my lipo is at 0%. Can a lipo be at 0% and charge well after ?
     
  6. bombastinator

    bombastinator ECF Guru Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    AFAIK no.
     
  7. jojaws

    jojaws Full Member

    Feb 12, 2018
    :(:(:confused:

    Ok, So i have to open my flawless in order to know more about the lipo and buy a new one...
     
  8. bombastinator

    bombastinator ECF Guru Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    I suspect a broken battery connection over an actual dead LiPo. Your chip should have protected you from that. The effect is the same though :/
     
  9. jojaws

    jojaws Full Member

    Feb 12, 2018
    I was wondered about that, ok :)

    I have just send a mail to my store and i'll wait an answer before open the box...

    Thanx !
     
  10. Steamer861

    Steamer861 Ultra Member Verified Member ECF Veteran

    Jan 13, 2014
    Canada
    Your # 2 Cell is Dead! :( This isn't all that uncommon, hopefully you get it replaced under warranty?
     
    • Agree Agree x 1
  11. jojaws

    jojaws Full Member

    Feb 12, 2018
    Thx Steamer861... I'm hopping for a warranty cause i bought the box one month ago...

    If i have to buy a new lipo, any tips for the choice/brand ?
     
    • Like Like x 1
  12. r77r7r

    r77r7r ECF Guru ECF Veteran

    Feb 15, 2011
    Pa,LandOfTaxes
    Happen to have a link handy for where you got that info, Sir? TY
     
  13. Steamer861

    Steamer861 Ultra Member Verified Member ECF Veteran

    Jan 13, 2014
    Canada
    If you get no help from the seller or manufacture, I would advise removing the battery, measure it, go from there. I run "Gens Ace" "Fully Max" & "Turnigy" All good choices IMO :)
    You need one that is the same size, 11.1 votls, 3S,

    Just look at the E-Scribe screen shots cell#2 is below 1 volt!
     
    • Like Like x 1
  14. r77r7r

    r77r7r ECF Guru ECF Veteran

    Feb 15, 2011
    Pa,LandOfTaxes
    Below 1 volt would be dangerous to try to recharge, correct? Escribe seems like a handy dandy thing!
     
    • Like Like x 1
  15. jojaws

    jojaws Full Member

    Feb 12, 2018
    Thx for this info !
     
    • Like Like x 1
  16. Steamer861

    Steamer861 Ultra Member Verified Member ECF Veteran

    Jan 13, 2014
    Canada
    The DNA will Not charge that battery! If one of the cells drops below a certain voltage (don't have that info handy right now) It will not charge the pack.
    I have had this happen before, one cell goes dead & the whole pack is dead :(
     
  17. jojaws

    jojaws Full Member

    Feb 12, 2018
    OMG. I am trying to charge for 4 hours :-/
     
  18. KenD

    KenD Vaping Master ECF Veteran

    Aug 20, 2013
    Stockholm, Sweden
    0% is probably the battery cutoff, so 3.2v or so, not 0v.

    Sent from my Thor E using Tapatalk
     
  19. Mr. Relentless

    Mr. Relentless Super Member ECF Veteran

    Oct 17, 2017
    Did you store it with low batt life. Cell 2 is low and most lipo chargers will not charge below 3v or so. I would bring it to a hobby shop that sell rc cars. They have lots of knowledge on lipo batts and can safely boost charge it for you over 3v if they feel it's safe. Might even have a new 3 cell that will fit.
     
  20. Mr. Relentless

    Mr. Relentless Super Member ECF Veteran

    Oct 17, 2017
    Also could be from not fully charging. Lipos need to balance. One cell might be full charged at 4.20v and the other 2 might need a hour to get to the same volts. If you can resurrect your battery you might need to leave it on the charger over night to balance the cells because they are so far off. They should only be about .05 off from eachother normaly. I have rc cars planes and helicopters and waiting for cells to balance is a pain and its slow but it has to be done.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice