The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Got my 016 + 510 Cartomizers

Discussion in 'MadVapes' started by mcl5000, Jul 15, 2010.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. mcl5000

    mcl5000 Super Member ECF Veteran

    Jul 15, 2009
    Allentown, PA
    Hey all. I just got my 016 battery (just 1 to try it out) and 510 cartomizers in the mail and I have a couple questions.

    First of all, the battery is pretty awesome. I love the look and size of it. I'll have to see how long it lasts me, but so far I'm very happy with it.

    Anyway, my problem comes from the 510 cartomizers. For some reason, it's like I need to take a 10 second drag to even get the carto to heat up. If I use it back to back to back, it works pretty well on those 2nd and 3rd drags, but if I take a drag every couple minutes, I pretty much get nothing.

    Is this how these 510 cartomizers generally work? It just seems like they take forever to heat up.

    That being said, when they get heated up, they're pretty awesome.


    edit: thanks for the extra free bottle of juice :)
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice