The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Problem With V8-Q4(5.0T) Coil for TFV8 Cloud Beast

Discussion in 'Atomizers and Cartridges' started by pronickle132, Nov 7, 2017.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. pronickle132

    pronickle132 New Member

    Nov 7, 2017
    Basically, my V8-T8(6.6T) coil got burnt so I switched it out with another one in the box, the V8-Q4(5.0T). After about a week it just stopped working then my mod, Sigeli 230 watt, kept saying check atomizer. I thought it was a problem with the 510 connector, however, the other coils from the package work it's just the V8-Q4(5.0T) that doesn't work. I have opened my tank thoroughly and have checked out the coil its self. Nothing is wrong with it. I have tried to contact SMOK but they still haven't responded. Can anyone please help me understand this problem?
     
  2. wheelie

    wheelie Ultra Member Verified Member ECF Veteran

    Feb 12, 2014
    Ont. Canada
    Rub your finger around bottom of coil and check for a wire sticking out. It will ground out on tank. A magnified glass works wonders to see the little fine wires. Cut it back closer to the rubber grommet. But with eight coils inside I assume when factory built it the grounding out is done at the factory and is inside the coil which can not be fixed very easy. CHEERS!
     
    • Like Like x 1
    • Agree Agree x 1
  3. Wraith504

    Wraith504 Ultra Member Verified Member ECF Veteran

    Aug 25, 2014
    New Orleans, LA
    if it works with the other coils and only that coil says check atty then it is obviously the coil.
     
    • Agree Agree x 2
  4. stols001

    stols001 Mistress of the Dark Nicotinic Arts Verified Member

    Supporting member
    May 30, 2017
    Tucson, AZ
    Those coils must be difficult to manufacture, as this is actually a pretty common problem. If you are happy with the performance of the other coils, I'd suggest using them. If not, you're going to have to learn to deal with some wire snipping I think, it seems to be a common complaint for those coils. With the cost of them, I personally wouldn't buy them (not that I would anyway, I don't think I need an octocouple coil, though I am a non-DL/sub0hm vaper....

    Good luck,

    Anna
     
    • Like Like x 1
  5. gofishtx

    gofishtx Vaping Master Verified Member ECF Veteran

    Jan 24, 2014
    Tomball Texas
    I would still think its a problem with the 510 pin. Every time you change a coil, you are removing the tank from the 510 connection so it may be getting contact sometimes but not others. It could just be that the 510 pin needs a good cleaning or it could have been pushed down so it's not making good contact or it could have a loose wire. Hopefully an easy fix or like you said just that one particular coil.
     
    • Agree Agree x 1
  6. Augmxnted

    Augmxnted Full Member

    Aug 28, 2017
    I had the same problem with the same kind of coil 3 days ago. spent 2 hours trying to figure out what was wrong. finally switched it out with another coil and bam! worked without a flaw. the problem with mass produced coils is that occasionally i guess you just come across a defective one.
     
    • Like Like x 1
  7. lellowyedbetter

    lellowyedbetter Full Member

    Dec 23, 2017
    Glasgow, Scotland
    +1
    I've had numerous smok coils over the years with this very issue.
     
    • Like Like x 1
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice