The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Question about Protank mini

Discussion in 'New Members Forum' started by Zee2006, Aug 22, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Zee2006

    Zee2006 Super Member Verified Member ECF Veteran

    Aug 12, 2013
    Cincinnati, Ohio
    Evening all,
    I'm hoping someone can help me figure out a problem I seem to be having with my new Protank Mini.

    Until recently I'd been using Totally Wicked's V3 Clearomizeron a simple 650 ego battery. After reading all the good reviews I decided to try the Protank Mini. The 1st couple days seemed ok, I'm a lite vaper I need to charge my battery bout every other day and I only use about 1ml of e-liquid a day so I really don't need to take the thing apart very much. So last night the battery needed charged (I have 2 batteries, so charge one use one), when I put the new battery on it wouldn't work. I took it back apart fiddled with it a couple times, nothing.....took it apart again wiped the wick thingy off a lil with a dry paper towel, put it back together and it started working just fine...

    So just now I needed to re-fill the tank, put it back together... nothing.... I've fiddled with it takin it apart puttin it back together, wiped it off again like I did last night and still nothing.....

    am I missing something???

    I've had the thing 6 days.


    Added: 6:06 PM
    just tried to charge the wick and still nothing.
     
  2. murphyramone

    murphyramone Super Member Verified Member ECF Veteran

    Apr 18, 2013
    Rockford, Il
    It may be that you just need to pull the stem of the coil down a tiny bit (dont pull to much or it will pull out). The connectors on the batterys might be diffrent and one pushes it up just enough to make it to tall for the other. :2c:
     
  3. Zee2006

    Zee2006 Super Member Verified Member ECF Veteran

    Aug 12, 2013
    Cincinnati, Ohio

    Hey thank you, I think you could be right, right before you posted I switched the battery back to the one I took off last night and sure enough it worked. Soooo when I need to take it apart again I'll watch for that and adjust accordingly.....

    thanks soooo much !!

    :)
     
  4. Rickb119

    Rickb119 Ultra Member ECF Veteran

    Jul 20, 2013
    Greeley, CO, USA
    It may be the battery. My first kit came with 2 900mah ego style and I had problems with one of them almost from the gitgo. Ended up finally just tossing it. Try (with the battery turned off!) using something (a needle or pin) to gently pry up the center post. If that works, be sure to not fully tighten it onto the charger or clearomizer. It may last for a little while doing that but I'd suggest getting a back up. Then, get a back up for your back up. ;)
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice