The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

SX Mini Q Class problem - Wont fire

Discussion in 'General Vaping Discussion' started by Darren94, Jul 22, 2016.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Darren94

    Darren94 New Member

    Jul 22, 2016
    Hey all, long time lurker, first time poster new member. I have been vaping since 2012 and have soft spot for high end well made devices. I have many Evolv products and recently decided to join the SX Mini band wagon. I purchased a red Q class 12 days ago and have really grown to love its fit, finish, feel and features. However, my excitement for the SX line was very short lived.

    During normal use yesterday, it simply stopped firing. For a minute, i thought my batters were dead but unfortunately, that was not the case. Both showing 4.1 on the the multimeter. When the fire button is depressed in any mode or wattage setting, the mod reacts like all is normal. Voltage drops can be seen, live atty data is displayed such as voltage and ohms, and even the joule counter changes indicating normal usage The issue it that the Rda/tank/ Rta simply does not fire. (I have tired numerous atty's, numerous batteries, cleaned all connections, and attempted to update the firmware)

    Because the Q is so new, i cant find much information online regarding the issue. One other ECF member posted in the other Q class thread about the same issue and one person wrote on the Yihi page with no responses from Yihi. Web searches find similar issues with the SSX350 chip but, not able to land at any solid solution.

    Needless to say, i am very disappointed that a 12 day old high end device with a $200+ price point has failed. I have written to Yihi but, i am awaiting a response. Ay input from the more seasoned SX users?
     
  2. Txaggiesaunt

    Txaggiesaunt Ultra Member Verified Member ECF Veteran

    Mar 16, 2013
    Texas
    Have you tried just ever so lightly lifting the center pin up.
     
  3. Darren94

    Darren94 New Member

    Jul 22, 2016
    Yeah - even gently cleaned the 510 with a q-tip and light rubbing alcohol - no luck :(
     
  4. Eskie

    Eskie ECF Guru Verified Member ECF Veteran

    May 6, 2016
    NY
    If it's only been 12 days, I'd reach out to the vendor for a replacement. You shouldn't have to deal with that kind of failure so quickly on a mod like that.
     
    • Like Like x 1
  5. Darren94

    Darren94 New Member

    Jul 22, 2016
    Agreed but, i got it at my local shop. Have spoken with them and their vendor advised it has to be dealt with Yihi. Bummer... Back to the Dna 200's for now
     
  6. Txaggiesaunt

    Txaggiesaunt Ultra Member Verified Member ECF Veteran

    Mar 16, 2013
    Texas
    My local B & M has a 30 day return policy. I would check with yours. If they don't then I wouldn't do business with them again. All they have to do is send it back as a bad product as long as you still have the receipt and original box.
     
    • Like Like x 2
  7. Nonsmokinnurse

    Nonsmokinnurse New Member

    Sep 27, 2016
    Had the same issue with mine and I'm on my third one haven't dared to use temp control on this one and so far I haven't had any problems. The other two wouldn't fire after only a couple of weeks of getting it. Everything looked fine and the counter and all readings showed on the screen like normal, but pushed the fire button and nothing. Luckily my brick and mortar store was good about the issue and gave me replacements without any hassle but they came from the same distributor and batch so I'm crossing my fingers and hoping for the best. I did leave a response on yihi's Facebook page and got no response from them. I generally use only 316l stainless and was surprised that it was not an option in temp control. Just a lot of hassle for a $200 mod in my opinion I've had this one for a couple months now but shouldn't have to worry about using the features of a "high-end" mod. Although I must say that it worked wonderfully and better than my DNA 200 but I had issues with the charging port on that contacted evolve sent it in and a week later had the mod back and working better than ever.
     
  8. Stinkytofus

    Stinkytofus Ultra Member Verified Member ECF Veteran

    Jul 30, 2014
    New York City
    Using ml, no issues yet
     
  9. smokinGAVIN

    smokinGAVIN Super Member ECF Veteran

    Sep 2, 2014
    Manila, Philippines
    Probably a bad batch. I have been using mine everyday and I have no issues. I don't do temp control though. 24 to 26 guage kanthal in power mode.
     
  10. redhunglow

    redhunglow New Member

    Oct 20, 2014
    beaverton, Oregon
    Mine lasted 5 months, and is now doing the same thing, it's toast

    Sent from my SM-N930T using Tapatalk
     
  11. Staghorn

    Staghorn New Member

    Nov 2, 2016
    so is mine.. stop firing today.. sucks
     
  12. cem aydın

    cem aydın Full Member

    Jan 29, 2017
    is there any solutions, because mine too stop firing...

    do you know how to reset chip??
     
    • Like Like x 1
  13. JARD

    JARD Full Member

    Apr 27, 2016
    Has anyone found a fix? YiHi has agreed to fix mine for $20, but the horror stories Ive read about these getting “lost” in the mail, or YiHi not returning them for months; they are located in China.

    I paid $200 for it through ebay, and the vendor is no longer active.

    The screws are apparent glued into the mod threading, making nearly impossible to take the board out unless you can ever so carefully melt the glue enough to where unscrewing becomes possible with a blow dryer.

    Or does anyone know a reputable USA located business that can fix this issue?
     
  14. cem aydın

    cem aydın Full Member

    Jan 29, 2017
    I will sent to chine yihi factory for fixing my mod, they said me that we could fix it in 5 minute... they did not say about solution...
     
  15. oldude 61

    oldude 61 Senior Member ECF Veteran

    Nov 22, 2014
    Frankston Tx.
    what does it say in the bottom right hand corner?
     
  16. RayofLight62

    RayofLight62 Super Member ECF Veteran

    I have an Sxmini Q mini, and every time I replace the batteries, it says "Check Atomiser" altough the Kabuki is there and in perfect working order. I have to turn it off and on again to make it working. This happen with the minimini set in power mode.
    For the rest the mod is flawless, great taste and signal purity, and extremely high conversion efficiency. It has a couple of minor issues with battery charging. It will only start charging when the battery voltage falls below 8.1 Volt, and the third digit of the battery voltmeter flickers randomly; I initially thought of a noise issue, but the problem is causes by the voltmeter having three digit and only eight bit of resolution. Furthermore, the battery meter is capped at 8.40 Volt, I can't fathom why. Also, the Q class is not able to vape while charging. All this corners cutting on the charger of such expensive device make little sense in my opinion.
     
  17. Sonic525

    Sonic525 New Member

    Apr 24, 2013
    USA
    Any updates on a fix?
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice