HELP! Is my device ruined?

Discussion in 'New Members Forum' started by TheWarmth88, Feb 10, 2014.

Thread Status:
Not open for further replies.
  1. TheWarmth88

    TheWarmth88 Full Member

    My apologies in advance if this is the wrong forum, but my post count isn't high enough for the model specific discussion.

    My eVic worked like a champ for about one month, then I started getting the tell-tale "No Atomizer Found" message uncomfortably often. All signs pointed to the center button being pushed too far down, so with a baby flat-head screwdriver I lifted it slightly enough to make the right connection. It kept working like a charm, and only every now and then I've had to lift it again on occasion (this was also still with an air-flow regulator, so my threads are fine and it would do it with or without the adapter attached).

    Last night, however, it randomly quit working. "No Atomizer Found" was popping up with ANYTHING I attached. I've lifted the pin several times, tried 4 different resistance cartos, attached my hypertank (protank heads), and tried lowering the pin on any of the cartos or the atty head. I stopped by the local vape shop and they happened to have an eVic--my tank worked just fine on theirs. I'm barely past the 30 day warranty period from MyVaporStore, so it looks like I'm screwed when it comes to a return or exchange.

    Did lifting the pin too many times entirely break the connection to the device itself? I have absolutely no idea what else to do with it, and the thing seems pretty dang hard to entirely disassemble.

    I'm back to my puny little 900mAh Inferno batteries and I just want my mod back! :( Any advice would be greatly appreciated!
  2. TheReign

    TheReign Ultra Member ECF Veteran

    Messing with the pin could have had something to do with it. No experiance with those devices. If it still turns on and just says no atty found it could be that it's not making connection anymore, causing it not to work.
  3. TheWarmth88

    TheWarmth88 Full Member

    I'm definitely getting no connection at all, but lifting the pin isn't working anymore. I feel like my best bet would be finding a way to take it apart entirely and try to diagnose from there.
  4. Sthur

    Sthur Vaping Master Verified Member ECF Veteran

    Hello, sorry to hear you evic is not working. Joyetech says shops are suppose to offer a 2 month warranty.

    Warranty Terms and serial number function

    All else contact joyetech they should offer a 1 year warranty as well.
  5. Rickajho

    Rickajho ECF Guru Verified Member ECF Veteran

    Supporting member
    Wow, I don't hear this problem with eVic's. The wiring to the atty connector is quite heavy duty in there but there is always a possibility that pulling a post on any device too far can break a connection.

    Is this a new model or a first generation version? Unscrew the beauty ring and look at the base. The new version has two screws holding the base to the eVic head. Older versions are only press fit. It will give you an idea as to how easy yours will be to disassemble.

    But before you go the disassembly route I would push the warranty issue real hard.
  6. TheWarmth88

    TheWarmth88 Full Member

    It's the new version, and I just realized the problem.

    After taking out the two small screws, I just had to use that same baby screwdriver to lift the top of the head from the unit. The wiring to the atty connector was actually anything BUT hardy--there was a bunch of white insulation where the hot wire runs to the connector, and as soon as I opened it, it just fell out of the insulation. I scraped most of it out so I could see the bottom of the connector, and as soon as I touched the hot wire to it, it worked like a charm. Looks like a drop of solder will fix it right up.

    I'm amazed at how horribly the red wire was attached to the connector. Everything else is rock solid in there. Weird.
  7. TheWarmth88

    TheWarmth88 Full Member

    Heh... yeah, the warranty route is just so responsible and involves so much patience... I mean, that's me to a T... hehe... yeah... :D
  8. Rickajho

    Rickajho ECF Guru Verified Member ECF Veteran

    Supporting member
    Really surprised. Maybe they thought they could use lighter gauge wire since the screw down version won't fall apart if you drop it. :laugh:

    Seriously, watch the screwing down of devices onto any PV. Stuff doesn't need to be screwed down more than finger tight. If you can't unscrew the clearo in a one handed operation - that's too tight.
  9. TheWarmth88

    TheWarmth88 Full Member

    I know, right?! Hell, I went for the thing because it seemed hardy enough to handle my clumsy self! It's been dropped maybe two times. Do you think not having all of that insulation will affect anything very much? I'll have no problem soldering it, but I'm wondering if I should put something else in there (wood glue, perhaps?) just to keep everything tight. I'm not too concerned either way since everything above the circuitry is pretty bare-boned.
  10. Rickajho

    Rickajho ECF Guru Verified Member ECF Veteran

    Supporting member
    Is it bare wire now? If it is I would replace it with something. Better idea might be pulling some copper wire out of a short piece of wire, leaving you the empty, uncut piece of insulation to slip over the exposed wire in the eVic.
  11. TheWarmth88

    TheWarmth88 Full Member

    I only stripped less than .5mm off of it just to get a connection, so the bare wire is minimal. Plus the insulation didn't really "slip" on or off... it was a bunch of dried putty-like stuff they used. I'll probably just give it a good coating of silica once it's done to keep everything nice and clean.
Thread Status:
Not open for further replies.

Share This Page