Manual eGo battery stuck "on"

Discussion in 'Battery Issues' started by Brego, Nov 13, 2010.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Brego

    Brego Senior Member ECF Veteran

    Joined:
    Nov 7, 2010
    Location:
    Where the corn grows tall
    One of my brand new Janty eGo batteries is stuck "on". Clicking the button has no effect and the button does not light up. As soon as I screw on an atty it starts sizzling. This battery has only been charged twice. Is this common or just a fluke? I found one other thread where this was mentioned. Has this happened to others? I'm glad I have my 510's as backup.
     
  2. 191ahc

    191ahc Senior Member ECF Veteran

    Joined:
    Oct 1, 2010
    Location:
    Berkeley, CA
    Yes, I had this happen also. The vendor did an exchange despite it being out of warranty by a week.

    My theory is that there is something in the button and its return string that needs some QC work.

    Dropping the eGo may be enough to cause the button/return spring/switch to fail. IMO. (Although I have dropped them many times and had only one fail...YMMV)

    Mistressnomad has some cogent thoughts on this too.
     
  3. Brego

    Brego Senior Member ECF Veteran

    Joined:
    Nov 7, 2010
    Location:
    Where the corn grows tall
    My battery's switch functions okay, and clicks up and down, it just doesn't do anything all of a sudden and doesn't light up. The battery is just stuck "on".

    I haven't dropped mine or anything. In fact, I put it in my case after charging it and when I pulled it out to use it, it was like this. The case was just sitting open next to my computer the whole time. Go figure.
     
  4. 191ahc

    191ahc Senior Member ECF Veteran

    Joined:
    Oct 1, 2010
    Location:
    Berkeley, CA
    Guess its time to send it back to the vendor. Sorry!
     
  5. tardcore

    tardcore Senior Member Verified Member ECF Veteran

    Joined:
    Oct 1, 2009
    Location:
    pittsburgh, pa
    it's entirely possible that you've experienced a failure of the mosfet chip that drives (afaik) all factory 'batteries', which are actually a battery with a chip and a switch and an LED, more accurately called a power supply [510, ego/riva, etc). uncommonly, yours has died in the closed position. the switch on the outside of your power supply activates and deactivates the mosfet chip, the flow of current doesn't actually go through the switch (again, afaik). this is a relatively common occurrence when these batteries are used with low resistance atomizers/cartomizers, which draws more current than the mosfet (and the battery too, probably) are rated to handle. unfortunately, most vendors (and manufacturers) have been either ignorant or dishonest (or a bit of both). low resistance atomizers/cartos (around 1.5 to 2.0 ohms) require around 2.5 amps of current to reach 3.7 volts, and factory power supplies with their mosfet-driven batteries aren't capable of putting out this much current for long. sometimes they just simply last less and less time per charge (the battery slowly loses capacity) and sometimes the mosfet dies. even if you weren't using a low res atty/carto, it seems most likely that your mosfet has died. there's nothing that can be done to resurrect this kind of battery with this kind of failure (one more time, afaik). hope i've been helpful. i'm a bit tired and kinda feel like i'm rambling..
     
  6. Brego

    Brego Senior Member ECF Veteran

    Joined:
    Nov 7, 2010
    Location:
    Where the corn grows tall
    Thanks tardcore, that was an informative comment. I hadn't really given much thought to the details of the failure, but I'll bet you are correct. No, I haven't been using LR attys because I had read here at ECF about that issue. I think I just got a dud battery. Still waiting to here back from the vendor to see if they will replace it.
     
  7. MikeDblue

    MikeDblue Full Member

    Joined:
    Oct 3, 2010
    Location:
    California
    The same problem just happened. I've had my Ego about 5 weeks and all was well until out of the blue the button stuck on and the button light was out. I contacted my vendor and he won't replace it but will give me store credit of $8 towards a new battery. After I contacted him, the next day my 2nd Ego battery did the same thing. I'm still waiting for the vendor to answer my 2nd email. I am reluctant to get another Ego battery. I do have 510 that I'm using. Vendor is local and out of town visiting right now.
     
  8. Scottbee

    Scottbee Vaping Master ECF Veteran

    Joined:
    Sep 18, 2009
    Location:
    Okauchee Lake, WI
    Yes and no....

    I've repaired literally dozens of eGo/Riva batteries with either "blown" or "stuck" MOSFETs. By-design, the MOSFETs should have no problem handling regular and LR atties/cartomizers. Anything above 1.1 Ohms generally works fine.

    You run into problems when atomizers or cartomizers begin to malfunction. Sometimes instead of just "popping" and going "open" the atomizer or cartomizer will semi-short internally. When this happens the resistance can drop into the 1.0 Ohm range and the MOSFET will fail. But note that if the atomizer or cartomizer develops a "dead short" (below .2 Ohm or so) the circuitry inside of the eGo/Riva will usually detect it and shut off.. saving the MOSFET. So there is a range of resistances that can cause the eGo/Riva to fail. But most if not all LR atties and cartomizers are above that range and are "safe".
     
  9. MikeDblue

    MikeDblue Full Member

    Joined:
    Oct 3, 2010
    Location:
    California
    Thanks for the info. I used the same atomizer on my 2nd battery and that probably caused the 2nd battery to fail.
     
  10. Scottbee

    Scottbee Vaping Master ECF Veteran

    Joined:
    Sep 18, 2009
    Location:
    Okauchee Lake, WI
    Yeah.. sadly that's kinda common. Folks will move a bad atty around from battery to battery, not realizing that the atty (or cartomizer) is sequentially destroying every battery that they screw it on to. When they finally figure it out, it's too late.
     
  11. mrp978

    mrp978 Full Member

    Joined:
    Oct 16, 2010
    Location:
    Tewksbury, Ma
    so is ther a way to "reset" this or is the battery NG? It just happened to me on a T-Rex unit. How can you fix it if possible?
     
  12. JoeyKay

    JoeyKay Senior Member ECF Veteran

    Joined:
    Feb 21, 2010
    Location:
    SC
    I've had this happen with four eGo batts and only with LR attys. . .which is odd, because everyone RAVES about how awesome the eGo is with LR attys. Same as the OP each time: It hits great for a while, and then the light in the button stops working, and it won't stop discharging. New or old batts, happens every time. Just lost a brand new eGo batt an hour ago like this. Thankfully, my Leo is arriving today, or I'd be screwed. People: DO NOT TRUST LR ATTYS ON EGO BATS! I don't know if the XL eGo bats are any different, but every eGo batt I have ever owned has sufered the same fate, regardles of the age, brand, and quality of the LR atty in question.
     
  13. spudboy

    spudboy Full Member ECF Veteran

    Joined:
    Sep 16, 2009
    Location:
    Washington
    This just happened to me, and I wasn't using LR attys. Both of my batteries are dead. Damn!
     
  14. zoiDman

    zoiDman My -0^10 = Nothing at All ECF Veteran

    Supporting member
    Joined:
    Apr 16, 2010
    Location:
    So-Cal
    Learned that one the hard way myself.

    Hey I don't know an IC from PCL but I did have a manual battery that stay on when I first got it. Found that if I rotated the button about 180 degrees it cured it. It never did it again.

    Mechanical things make sense to me. If it is a board bases issue then it gets chucked in the round file. That or it gets a date with the band saw.
     
  15. lamer

    lamer Senior Member ECF Veteran

    Joined:
    Jan 7, 2011
    Location:
    NV
    I had one eGo PT and one eGo T batt do this in the same week. Both were brand new. I use genuine Joye 510 attys and it was brand new as well, and it was on the "dry burn the new primer off" cycle. Now one won't fire and the other is continuously firing.
     
  16. dmnall

    dmnall Full Member

    Joined:
    Mar 23, 2010
    Location:
    Goleta, CA
    Hey Question for you,
    How do you repair the batteries that do this? I have one of my original ego batteries literally do this just 5 minuets ago, not a big deal to have a dead battery as I have 3 spares, but I would not mind fixing the standard battery to still have a total of 2x standard 650 mah 2x mega batteries. I tried putting the same atty back on the battery and it is still stuck on, I guess leave the battery alone and let it die? Not sure first battery ever to do this in over a year now since I started vaping.

    Cheers,
    Charlie
     
  17. Katatonik

    Katatonik Ultra Member ECF Veteran

    Joined:
    Jan 14, 2011
    Location:
    Dallas, TX
    I believe this happened to me once. I was vaping fine when all of the sudden my cartomizer emitted horrible smoke. My battery died (even though it was maybe half way through its charge). It wouldn't turn on or signal a dead battery. Fearing the worse, I just plugged it back in to the charger and it eventually charged. Since then I have had no issues with it. So try that. Just put it in the charger.

    Also: How old is that battery? If you've had it since you started vaping it might just be dead totally. They only last about 300 charges.
    And thank god you have spares. I learned the hard way when I started vaping the importance of spares--even spare chargers.
     
  18. Da_zees

    Da_zees Full Member

    Joined:
    May 7, 2011
    Location:
    Fort Worth Tx
    I had an atty start to fail and it has blown the chip. well, that sux.
     
  19. Ethos

    Ethos Full Member

    Joined:
    Jul 20, 2011
    Location:
    Northampton, UK
    Ive had the exactly the same problem. one battery to kill them all. my one was from Ivapour UK and the last time i spoke to the vendor toby he was less than helpfull. will try again to get a refund. This vapeing is almost as expensive as smoking!!!
     
  20. joeman

    joeman Senior Member ECF Veteran

    Joined:
    Mar 31, 2011
    Location:
    Lake Toxaway, N.C.
    I just had a similar problem. My ego type batts are 900 mah. I had just received a mega dual coil carto and filled it with its 3.5 ml of juice. No leaking so screwed it into the batt I had been using for some time and it fired smoked like a charm for a minute when I discovered it started firing and didn't stop. I had to unscrew it to stop. I figured it was the batt, now 4 months old so I screwed in the second batt. fully charged, checking for a leak first and bam killed the second batt. dead as it fired, not stopping. I switched to an atty and cart and nothing. I charged the 1st batt. and the light never turned blue but reddish blue and never worked again nor the second. Good thing I had my backup. I will post what the supplier says when I hear back. I expect the mosfet chip as well but why to both batts???
     
Thread Status:
Not open for further replies.

Share This Page