The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Boge Revolution 2 Trouble's

Discussion in 'Ecigarette Technical Issues' started by Löki, Jan 29, 2011.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Löki

    Löki Senior Member Verified Member ECF Veteran

    Sep 27, 2009
    I got my order yesterday with the revolution and I think it may be defective.


    And very confused about the charging. I set the led to red, And when I plug the unit in the led turns blue and never changes. Its been plugged in for over 6 hours now and the led is yet to change color to indicate its done charging. And was plugged in for 4 hours yesterday. Also in the instruction book it says the led will flash 3 times when plugged in to show its starting to charge but it does not blink when plugged in it just turns blue and thats all. It how ever does blink red 3 time's when the power switch is turned to on when it's not plugged in.

    Am I missing something? Or is the unit defective ?

    I used the unit for about 2 hours (Heavy Vaping) yesterday thinking it may have come precharged and the blue color was indicating it was done charging. But after using it and plugging it back in still just a blue light.

    It vapes fine but I have not been using it today because I'm not sure if it's defective or not And would hate for something to blow up on me or something LOL


    I'm asking for advice or any info user's of the unit may have to offer before returning it for a replacement. I was told it's very odd for the unit to act like this and offered a exchange.(Gota Love LiteCig) But would prefer to get it figured out if at all possible...

    Also wanted to point out that I did try other usb cables also tryed my computer usb and a wall adaptor from my 401, But it's always the same thing. I also tryed to reset the unit with the software with no luck.


    Thanx


    ö
     
  2. Eighttrucktires

    Eighttrucktires Super Member Verified Member ECF Veteran

    Jan 6, 2010
    Missouri
    Mine acts like that too. I will be different if you let it discharge more. Sure puts out the vapor, huh? It gets better the more I use it!
     
  3. Löki

    Löki Senior Member Verified Member ECF Veteran

    Sep 27, 2009
    Yeah it put's out a real nice flavor and vapor. Very close to a 901 flavor with a 510 vapor. Nice throat hit but not too much.

    So your saying if I use the unit and run down the battery it will charge properly ? And the led will start working ? ?


    Thanx


    ö
     
  4. Eighttrucktires

    Eighttrucktires Super Member Verified Member ECF Veteran

    Jan 6, 2010
    Missouri
    I have never had mine run down far enough to tell. (charge it every night) Mine acts like yours does. I think the charging lights would behave if I let it run down.....
     
  5. Löki

    Löki Senior Member Verified Member ECF Veteran

    Sep 27, 2009
    Well I have been trying to run the battery down, I figured sence solid state led's don't burn out I would just leave it on all night but this battery will not die LOL .

    I must say eventhou the charging light is not working properly ( Yet ) And the fact that it does not work as a passthou with really makes me sad, I really really like it. I don't understand why boge didn't make it work as a passthou.

    I will update this topic when the battery die's and let you all know if it worked out, or got sent back for a replacement.

    ö
     
  6. Löki

    Löki Senior Member Verified Member ECF Veteran

    Sep 27, 2009
    Battery finally ran dry and the led worked properly to indicate the battery was dead, But when plugged in to charge it was still the same story. LED turned blue and never changed. It did charge and work seemingly fine but never reported a full charge so The unit is being returned for a replacement.

    I really like the unit and can't wait for the replacement ! And plan on doing a full review ( A First for me ) when the new one get's here, Also plan to update the review with atty life report's.

    As a matter of fact I like the unit so much I'm temped to order a backup revolution, But think I will wait and see about the life of the atty.


    ö
     
  7. berger

    berger Senior Member Verified Member ECF Veteran

    Sep 2, 2010
    Carvahall
    The unit is blue when plugged into a computer indicating communication enabled. When plugged into a usb wall wart it will turn red. I think it still charges when hooked to a computer but not positive
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice