The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Help with Defiant Designs DS

Discussion in 'Mech Mods' started by Jugband, May 24, 2020.

Tags:
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    I just got a Defiant Designs DS in the mail today. I was thrilled to try it out. Unfortunately I have a serious issue from the first use. I have been vapeing for several years. Almost exclusively on mechanical squonk mods. I have a lot of experience with them. Unfortunately I’m having serious issues with this one. After I received it today I watched a video on YouTube to be certain to use the mod properly. I then loaded it with juice, two fresh Sony VTC5A batteries and an RDA. At first it was perfect. About two or three hours later it became very weak. I pulled the batteries and put them on a charger to check the voltage. One battery was at 4.1 the other was at 3.45. I knew something was very wrong. I put in two fresh batteries and the mod would no longer fire at all. I tried tightening the battery caps, nothing, tried loosening them, still nothing. I tried three different RDA’s, still nothing. I placed the original RDA that the mod wouldn’t fire, on another mod it fired right up. I’m very perplexed, in all my years of using mech mods I’ve never had issues like this. I prefer the simplicity of mechs over the issues of regulated mods. I really can’t understand what’s causing these issues. If anyone has any suggestions as to what could be wrong I’d be very grateful. Thanks in advance!
     
  2. 73neb

    73neb Super Member Verified Member ECF Veteran

    Supporting member
    Feb 27, 2014
    N. California Bay Area
    Have you taken it apart and looked at the button contacts? They may need to be cleaned. Also make sure the battery door and it’s groove are clean.
     
    • Like Like x 2
  3. gsmit1

    gsmit1 Super Member ECF Veteran

    Apr 19, 2018
    There's about 100 parts to that mod, but you'll have to take it apart. They gave you the tool. It isn't a clone right?
     
    • Like Like x 2
  4. Ben85

    Ben85 Ultra Member ECF Veteran

    Mar 16, 2014
    Kent, UK
    Really hard to help you without any visuals at all, however, this is a mech so it should be easy to rectify. Full strip and rebuild required.
     
    • Like Like x 3
  5. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    Yes, I watched the video on YouTube Followed it step by step. Completely broke it down cleaned with alcohol, reassembled still completely dead.
     
    • Optimistic Optimistic x 1
  6. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    Took it all apart and cleaned it. Still nothing. No, it’s not a clone. I ordered it directly from the site.
     
  7. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    Thanks everybody for the help so far. I do appreciate your time and help. I’m just absolutely perplexed I’ve been using mech squonk mods for several years. I was excited to try this. I agree it’s a full mech, should be a relatively easy fix. I just don’t understand? One thing I was surprised to see, right out of the box it was filthy. This photo is just from the battery/ bottle door. 693A3896-C62B-490E-A530-A61A399B29AB.png I did order the original from the site, this is not a clone.
    One other question I have. I understand these were originally made in part with 528 Custom Mods. Now they are being mass produced in China. I don’t mean any disrespect to the mod or designer, but is this a quality issue now? I’m just trying to understand this from people who may know more about this particular mod.
    Again, thank you everyone for the replies!
     
  8. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    Really nothing out of the ordinary to post a picture of. All looks exactly as it should. It’s really odd. I agree about the cleaning and rebuild. Tried it, nothing.
     
  9. UncleJunkle

    UncleJunkle Ultra Member Verified Member ECF Veteran

    Nov 29, 2010
    I did some quick searching on Google and I think I read that while that mod is built well, the firing button is considered to be a piece of cheap trash. I could be wrong, but that's what I think I read about that mod.

    Therefore, could be a bad firing button.

    Contact the retailer where you bought it and get resolution.
     
    • Like Like x 1
  10. gsmit1

    gsmit1 Super Member ECF Veteran

    Apr 19, 2018
    Actually there were some significant improvements, in the button actually, when Defiant Designs took it over. I don't remember all the details now, but some guys were able to sorta fix the original button. You must have a new one though if you got it from the DD site.

    Made in China doesn't HAVE to mean junk btw. What you show on the rag looks like oxidation just from sitting to be fair.

    It probably won't help, but here's mine all taken apart.
    ds_cr.jpg
     
    • Like Like x 2
  11. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    I have an update. I had some time to sit with it and go through it again. I wish I could pin point what the fix was other than cleaning, but the good news is I seem to have it up and running. Hopefully I won’t have the battery issue again. I’ll try it and see. I really have high hopes for this mod, it’s easy to see its very nice quality. I certainly didn’t mean to imply it was junk from China, I was just concerned since I had some issues. Glad to hear their were improvements when Defiant Designs took over. I thank everyone for taking the time to help. Here’s hoping I’m all set!
     
    • Optimistic Optimistic x 2
    • Like Like x 1
  12. gsmit1

    gsmit1 Super Member ECF Veteran

    Apr 19, 2018
    I have high hopes for you too :)

    I can only tell you that I have had mine for like a year and a half and literally zero issues. It is a great mod. There's always an answer. Possibly you have a defective part in there somewhere. That happens to the best of em occasionally. I can't believe that DD wouldn't take of that if so.

    BTW, I run my batteries positive up with the bottom contacts flipped over so that the slot is against the battery can. Always have.
     
    • Like Like x 1
  13. gsmit1

    gsmit1 Super Member ECF Veteran

    Apr 19, 2018
    It is indeed. Built like a tank. You could probably drop it down a flight of concrete stairs and it'd still work :D
     
    • Like Like x 1
  14. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    I appreciate ya gsmit1, you’ve been very kind!
     
    • Like Like x 1
  15. Jugband

    Jugband Ultra Member Verified Member ECF Veteran

    Apr 10, 2013
    PA, USA
    I wanted to post one final update. I had issues again periodically with only one battery draining. I emailed Defiant Designs. Customer service was fantastic. I received a reply immediately, and on a holiday weekend. He sent me a few suggestions to try. He got it with the first one. It was as simple as a battery wrap that was covering too much of the negative contact of the battery. I removed the wraps, got out fresh wraps that were from the same batch. I gave these a slight trim and rewrapped. Works perfectly now. I thought I would add this if anyone in the future experiences this. More importantly I wanted to point out, this is a fantastic mod. All my problems were user error and you can’t beat customer support.
     
    • Like Like x 1
    • Winner Winner x 1

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice