The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Madvapes VV Box Mod Stopped Working!

Discussion in 'MadVapes' started by STILLSMOK9, Feb 25, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. STILLSMOK9

    STILLSMOK9 Ultra Member ECF Veteran

    Okay, I have had my VV Box Mod for about 2 months now and last week It started giving me problems with the power switch. I read where if you flip the switch on and off a few times that it would work again. This trick has been successful up until last night... Last night it refused to work even after flipping the switch over and over. So I was bummed because I had to use my Ego only until I tried using an eraser and rubbing the battery connector points. WINNER, it started working great again. So this morning I fired it up and it worked fine, then I switched to a fresh set of batteries and now it will not work again!! :(

    Anybody have any ideas/suggestions that might help? Or is it ready for it's funeral?

    TIA
     
  2. dguer3rd

    dguer3rd Senior Member ECF Veteran

    Feb 17, 2012
    Beloit Wi
    My on/off switch stopped working too, but i dropped it on cement to do that. I pulled the switch cover off and hardlined past the switch to get it working again, basicly hotwired it. Now though i pull a battery when i put it in my pocket to avoid it going off in my pocket. Fried a few cartos before i figured that one out! :p
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice