The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Muted flavour Siren2 (Help needed!)

Discussion in 'New Members Forum' started by iuliangabriel97, Nov 1, 2018.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. iuliangabriel97

    iuliangabriel97 Full Member

    Jul 20, 2018
    Hi,
    For about 3 days I got no flavour on my siren2..
    Let me tell tou what I ve tried:
    Change different coils (also different positioning )
    Change cotton
    Wash the atomizer
    Tried different wattage
    I mention that it s not about the juice,it is the same that I used before, and it s not my vaper tongue because I gave someone else to try and he told me the same ( no flavour )
    I appreciate any idea.
    Thanks
     
  2. Storm52

    Storm52 Ultra Member Verified Member ECF Veteran

    Supporting member
    Jan 27, 2014
    Shreveport, LA
    Sounds as if you have used up all the flavoring in your juice. That's all I can come up with. :)
     
    • Funny Funny x 3
  3. iuliangabriel97

    iuliangabriel97 Full Member

    Jul 20, 2018
    It sounds funny and I believe it could pe possible under certain circumstances. But I don t think that it s in my case . Thanks for replying though
     
    • Like Like x 1
  4. Hawise

    Hawise Ultra Member ECF Veteran

    Supporting member
    Mar 25, 2013
    AB, Canada
    Very weird. I don't see how a functioning RTA could simply lose flavour. A coil might, but it sounds like you've covered that possibility.

    I have a few questions and/or suggestions:
    • It sounds like it was working fine before. Is that correct?
    • Have you tried different flavoured juices?
    • Have you tried it on different mods in case your usual one isn't firing properly?
    • Have you checked the resistance on another device? A problem with the tank itself that prevented it from getting proper power might show up that way.
    • Do you get the usual amount of vapour, or does it seem at all weaker?
    • You say it's the same juice you've used before - the same flavour or the same bottle? If it's a new bottle it's possible it wasn't flavoured properly.
    • Have you changed your nicotine levels?
    And that's all I can come up with at the moment. I hope you can sort it out - the Siren 2 is a nice tank.
     
    • Like Like x 1
  5. iuliangabriel97

    iuliangabriel97 Full Member

    Jul 20, 2018
    Hey,
    Thanks a lot for help. I was pretty sure that it was not mod fault and it was the same bottle that taste great a few days ago,and now its normal vapour production but got a strange flavour ( almost none ). Didn't see your comment but since I posted , someone advised me also to try another e liquid.I added on the same build and wick a mint flavoured e liquid and the taste is very normal. I just keep thinking that the liquid is the problem but I can t figure how..maybe because I did it myself (50ml consisting of : 5ml aroma,25ml base 70-30,2 nicshots of20mg/100ml) . Again ,thanks a lot for replying,I m glad that people like you still exists
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice