The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

No atomizer issue

Discussion in 'APV and Mods Discussion' started by Timshon111, Feb 25, 2018.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Timshon111

    Timshon111 Full Member

    Feb 25, 2018
    Hi everyone
    On my eleaf istick 30w, I accidently pushed fire button while my metal tweezer was touching the coil. My istick now does not recognize any atomizers. My questions are ...

    1. I assume that something got shorted.
    Is there a way to fix this?
    2. Would replacing a battery resolve this issue? (I dont know whether battery or something else is shorted)
    • Like Like x 1
  2. bombastinator

    bombastinator Ultra Member Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    Shouldn’t have done much. More likely there’s some dirt or whatnot in the 510 preventing connection
    • Useful Useful x 1
  3. Timshon111

    Timshon111 Full Member

    Feb 25, 2018
    It's clean and I never had this issue right until I pressed that fire button with tweezer on coil...
    • Optimistic Optimistic x 1
  4. bombastinator

    bombastinator Ultra Member Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    Hmmm. Were the tweezers open when you did this? I suppose it’s possible you touched one end to one end of the coil and another end to another and created a short. Still shouldn’t have destroyed the mod though. Those things are supposed to have short protection. It should have just shut down. “Should” is not always what happens though of course
    • Agree Agree x 1
  5. AzPlumber

    AzPlumber Vaping Master Verified Member ECF Veteran

    Aug 28, 2011
    "No atomizer" typically means an open circuit not a short. A short would usually show as "ohms (resistance) too low" or something similar.
    • Like Like x 1
  6. Northernshrink

    Northernshrink Ultra Member Verified Member ECF Veteran

    Jan 21, 2012
    Bracebridge Ont Canada
    Should not have done much but electronics can be a little squirrelly at times. I’m guessing you have tried powering the mod on and off and tried a different tank, rda etc ?
    • Agree Agree x 1
  7. stols001

    stols001 Mistress of the Dark Nicotinic Arts Verified Member

    Supporting member
    May 30, 2017
    Tucson, AZ
    I guess anything is possible although I'm not sure it is likely. I have been known to be wrong before. I would pull the battery, restart everything and (if you have any) try some different tanks on the mod. It could still be the 510 connection so you should probably test that out. Reset your device also by pulling it. Etc. I hope you find a solution but if not, I guess chalk it up to experience .I really actually thought the ceramic tweezers were used to get rid of heat but I guess if you left those tweezers on there for a bit, it could change the resistance of the coil somehow, did your mod do/act weird as it was happening... Was it instantaneous, is what I'm saying?

    In any case, if you can't figure out the solution or don't have other tanks to try, it may be time for a visit to your (best) local vape shop to see if they can help you out any as far as determining what is going on. Hopefully it's still under warranty, but I'd say visit the vape shop if you have continued troubles. They should at least be able to give you a more definitive answer...

  8. 93gc40

    93gc40 Vaping Master ECF Veteran

    Oct 5, 2014
    Dead shorting could have burned something inside the mod.... can it be fixed depends on what burned.

    Sent from my SCH-I605 using Tapatalk
    • Like Like x 1
  9. gpjoe

    gpjoe Ultra Member Verified Member ECF Veteran

    Oct 30, 2013
    I would have thought the mod would not have fired if the coil was shorted by the tweezers. After all, isn't that what "short protection" is supposed to do?

    I agree with Anna - pull the battery and restart the mod. If it doesn't work, take it back where you bought it or move onto something else.
    • Agree Agree x 1

Share This Page