The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Silver Bullet, o-ring around connector has come out

Discussion in 'Silver Bullet' started by johnnytwofingers, Oct 15, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. johnnytwofingers

    johnnytwofingers Senior Member Verified Member ECF Veteran

    Aug 24, 2012
    Vancouver, Canada
    I've been having trouble with my silver bullet, the o-ring that normally resides under(?) the centre connector that presumably prevents it from touching the sides came out of place when I was prying the connector up to try to remedy a problem of it not firing. I've been fiddling with it for some time now but can't get it to go back in place.

    Has this happened to anyone before, and is there some trick to it?

    I'll attach a picture so you can better see what I'm talking about:

    http://i.imgur.com/6PDhp.jpg
     
  2. johnnytwofingers

    johnnytwofingers Senior Member Verified Member ECF Veteran

    Aug 24, 2012
    Vancouver, Canada
    Ok solved it. pulled the center pin up quite a ways, then used two plastic toothpicks, one to hold one edge of the ring in place and the other moving away from that one around the pin, which forced the ring down over the lip of the pin so it ends up underneath the head of the center pin. Took a few tries but isn't too hard once you know how.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice