The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Smok X-Priv Firmware

Discussion in 'APV and Mods Discussion' started by Boodaddy, Jan 30, 2019.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Boodaddy

    Boodaddy Senior Member Verified Member ECF Veteran

    Jul 2, 2016
    Ohio
    Hey Guys,

    I've been having issues with my Smok X-Priv screen etc.. I couldn't find the firmware anywhere on the Smok site, or online. I finally heard back from Smok support, and they sent me the link to download it.

    It's a newer version "1.0.9" from the "1.0.8" version that shipped with my mod. (Nothing has visually changed)

    No instructions came with the file, so I made some below for people wanting to update.

    1. Open the HPT tool
    2. Take the batteries out of your X-Priv
    3. Hold down the fire button & plug in the USB cord to the X Priv
    4. Let off the fire button
    5. Click "Connect" on the HTP tool
    6. Click "APROM" under "Load File" and choose X-PRIV_V1.0.9.hex
    7. Make sure "APROM" & "Config" is checked under "Program" and click "Start"
    8. After the update is complete you will see "Pass" you can disconnect the usb cord, and fire it up.

    smok.JPG

    A lot of people have been asking for it, so here it is...

    Smok X Priv Firmware
    x-priv.rar

    If the Smok link above stops working just reply here, and I will upload a new link.

    Enjoy!
     
    • Informative Informative x 1
  2. tehooo

    tehooo New Member

    May 4, 2019
    perfect you just need winrar
     
    • Funny Funny x 1
  3. Noah27

    Noah27 New Member

    May 10, 2019
    Hi,
    when I click APROM i can't find the .hex file...need help
     
  4. Mordacai

    Mordacai Ultra Member

    Jan 16, 2019
    UK
    @Noah27, X-PRIV_V1.0.9 should be located in the folder where you extracted the files.
     
  5. bombastinator

    bombastinator ECF Guru Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    A SMOK mod lasted long enough that a firmware update became useful? Wow. That’s a rare bird there.
     
    • Like Like x 2
    • Agree Agree x 1
  6. vimagreg

    vimagreg Super Member

    Feb 9, 2019
    I thought the same!
     
  7. gsmit1

    gsmit1 Senior Member ECF Veteran

    Apr 19, 2018
    Thank you. Worked like a charm, and yes my X-Priv is over a year old, beaten half to death and works fine. Even for firmware upgrades.
     
  8. ian.wills

    ian.wills New Member

    Jun 12, 2019
    Just a tip to everyone, make sure you use the usb cable that came with your vape, otherwise you may have trouble connecting the HPT tool with your device.

    Thank you OP for sharing this! Amazing.
     
  9. Michael_S

    Michael_S Full Member

    Jun 9, 2018
    Does anyone know what changed in this version ?

    I just updated to 1.09.

    Thank you @Boodaddy for the file.
     
  10. Μιχαλη

    Μιχαλη New Member

    Jul 8, 2019
    καλημερα κατεβαζω το αρχειο αλλα δεν μπορει να βγει το rar ειναι ευκολο να το ξανα ανεβασεις ευχαριστω
     
  11. Michael_S

    Michael_S Full Member

    Jun 9, 2018
    Does by any chance someone have version 1.08?
     
  12. tachiro

    tachiro Full Member

    Jul 17, 2019
    i did just you sayed and my x-priv dies, do not turn on, can you help me
     
  13. Michael_S

    Michael_S Full Member

    Jun 9, 2018
    Can you still connect the X-Priv to your computer? If so, try to repeat the update process. But first, erase memory. This was necessary for my X-Priv,
     
  14. tachiro

    tachiro Full Member

    Jul 17, 2019
    yes i do, but how do you erase memory
     
  15. Michael_S

    Michael_S Full Member

    Jun 9, 2018
    Only Click on 'Erase all' on the tool and start.
     
  16. tachiro

    tachiro Full Member

    Jul 17, 2019
    still not working i just did that any other option
     
  17. tachiro

    tachiro Full Member

    Jul 17, 2019
    meaby it is the Firmware, can you upload the link again
     
  18. Michael_S

    Michael_S Full Member

    Jun 9, 2018
    Did you update the x-priv again after the erase all?
     
  19. tachiro

    tachiro Full Member

    Jul 17, 2019
  20. Michael_S

    Michael_S Full Member

    Jun 9, 2018

    try this:

    Hold all buttons WITHOUT batteries and plug into a USB port. Keep holding for ten seconds, throw batteries in while still connected, disonnect and reconnect to turn on. DO NOT TRY AND TURN ON NORMALLY. Use the cable....

    This will work on any __-Priv series mod.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice