The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

SMOKTech SID -- Issues??

Discussion in 'New Members Forum' started by Pork Dragon, Oct 31, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Pork Dragon

    Pork Dragon Full Member

    Oct 25, 2013
    Surprise, AZ
    So, I'm relatively new to vaping (about 5 months). I recently purchased a SMOKTech SID. It has been working great, except every now and again, the screen will read "short" and will not fire. Is this a common problem with this mod? And, if so, how is this prevented if it's something I'm doing?
  2. loislolalane

    loislolalane Senior Member ECF Veteran

    Oct 21, 2013
    I have had mine for a few weeks and searched these forums extensively before the purchase and I have neither had that problem, nor read anything that would lead me to believe it was a common problem. Have you tried a different battery, maybe?

    Living, loving, and laughing all the time!
  3. Pork Dragon

    Pork Dragon Full Member

    Oct 25, 2013
    Surprise, AZ
    Well I'm using Efest IMR18650's. I have 2 of them and it happens using either battery. I mean, it's definitely not a big problem it happens maybe 2 times out of 100 so. I was just wondering if I received a defective mod.
  4. Baditude

    Baditude ECF Guru ECF Veteran

    Apr 8, 2012
    Ridgeway, Ohio
    Regulated mods have built-in protection circuitry within their processors. If the protection circuit detects a short somewhere in the electrical chain from the battery to the coil in the juice device, it will refuse to fire and display an error code.

    The trick is to find where the short is. It more than likely is the coil in your juice attachment, but it could be anywhere from the battery, the fire switch, the top connector pin, to the atomizer.
  5. Pork Dragon

    Pork Dragon Full Member

    Oct 25, 2013
    Surprise, AZ
    Could it possibly be a bad control head?
  6. brittany29

    brittany29 Full Member

    Oct 31, 2013
    smoktech is a cheap china sure they only go with that go ahead and checkout and after that possibly vaporpassion they use different suppliers and try out there product therefore a better outcome, this might work better for you.:2cool:
  7. efinch

    efinch Full Member

    Jan 15, 2013
    Just a shot in the dark, are you using a kanger clearomizer or tank or any bottom coil. If so check the atomizer head near the rubber grommet to make sure no wire from the legs are sticking out. If so push it back under the rubber or clip it off. This usually causes a short as the wire makes contact with the base of the tank. If your not using any of these ignore what I've just said lol :)
  8. jifjifjif

    jifjifjif Vaping Master Verified Member ECF Veteran

    Mar 11, 2011
    Vape Canaveral, FL
    I also just got a SID from a local brick and mortar shop and occassionally get the "short" code, but like you said, it's maybe twice a day out of 500 presses of the button. I just let go of the button and re-fire. I have not tried to figure out what it is.

    I am using AW IMR 18650 batteries in it. I am running a Vision Victory tank on top which uses the EVOD/Protank bottom coil heads.
  9. Ddippel

    Ddippel Senior Member Verified Member ECF Veteran

    Had this happen to two of my SID's what I found, is that almost imperceptably, the entire top "Deck" of the SID had started to pop out of the tube, a few taps of a hammer (and I do mean TAPS) pushed it back inside nicely and the error code stopped. Of course it started again any time I dropped the device, but then a few more taps cleared it again. I am not sure what the exact problem was but this was at least an easy fix
  10. Pork Dragon

    Pork Dragon Full Member

    Oct 25, 2013
    Surprise, AZ
    I will definitely be checking this from now on...thank you
  11. Pork Dragon

    Pork Dragon Full Member

    Oct 25, 2013
    Surprise, AZ
    I wasn't using a kanger on it, BUT I checked out all my heads that I had used on it and all of them had a little piece of the coil wire sticking out from the bottom. I tucked it back in and haven't had an issue since :) thanks again for the heads up
  12. HawaiiVPR

    HawaiiVPR Moved On

    Oct 19, 2013
    808 State
    Seriously? Cheap China brand?? All the items on seem to be cheap Chinese copies of "cheap China brands." Its pretty annoying when opportunistic retailers start telling customers that all other products are cheap trinkets from China when in turn all the stock they carry are from the same place.
  13. JulesXsmokr

    JulesXsmokr Ultra Member ECF Veteran

    lol -- my CCB - er I mean my SID has been 99% flawless since I bought in August. Only an occasional misfire here or there, nothing that can't be remedied by pressing the firing button again...:2cool:
  14. BiglerLA

    BiglerLA Full Member

    Sep 30, 2013
    Cleveland, Ohio
    Only problem I have had with my SID if the wattage likes to change on me. I am sure this is operator error but it does get annoying. I have only had it a week or so. I am sure I will get used to it and this problem will go away. Would be nice if I was able to lock in the watts.
  15. SEE47

    SEE47 Full Member

    Jul 25, 2013
    i been using my sid for about a month, i only started having this issue when i build my own nano coil on the pro tank. however its not the sid acting out on my case its just the way i build my nano coil, as soon as i go back and fix it i have no issue. so all i can say is that the sid seems to work just fine for me.
  16. MrCobble

    MrCobble Unregistered Supplier

    Sep 11, 2013
    Orlando, FL
    Has anyone had a problem with the white ring on the bottom-side of the head moving flush with the center brass pin? (Or the center brass pin falling flush with the ring?). Also, on another SID, the voltage keeps resetting. Annoying!!!!
  17. agt7575

    agt7575 Full Member

    Yes I have had the same issue. In fact, this issue has caused my SID to stop working all together after only 3 days of use. My wife's SID (which was purchased at the same time from the same vendor) has the bottom pin sticking out about 1/16" from the white plastic ring, and her's works flawlessly. I noticed the difference right away as my unit came with the pin flush against the white ring, and it never worked correctly and the functionality fell off with each day of use.

    I think its a manufacturer's defect. I requested an RMA from the site I purchased it from so I can exchange it for a new one. Hopefully it all goes well. Will keep everyone informed.
  18. mrsheathercastro

    mrsheathercastro New Member

    Nov 14, 2013
    I purchased a Sid at a vape shop, I had nothing but problems
    with it, after a few days they told me the center pin was pushed down by screwing my atomizers in too tight. Then it would not turn on when I pushed the button to vape. After returning to the shop they kindly exchanged it for an MVP. At christmas I saw a great sale on the Sid and decided to give the device another shot since everyone loves theirs and now this one is worse. The shop I bought the original one from told me they are seeing lots of people having problems. I need help!

  19. Whiskey River

    Whiskey River Full Member

    Sep 17, 2013
    Yes it happened to mine too. I took a knife and pried it back out and it's been working great ever since. Even stopped it from bouncing around the wattage mode. Mines about 4 months old. My batteries fit pretty snug and I think that was part of the problem
  20. Whiskey River

    Whiskey River Full Member

    Sep 17, 2013
    Make sure you load your battery from the bottom. I always used to unscrew it from right under the head to replace the battery because it was easier to push the tube into place instead of the cap. I think this puts extra stain on the brass contact pin under the head and causes problems. I also carefully drilled a small hole in the white plastic ring around the brass contact under the head and sprayed some electrical contact/circuit cleaner in the head after I pried the brass pin back out and it's been working great. It got to the point where it was constantly changing wattage and then wouldn't fire unless I pressed the fire button really hard, then I saw how the brass contact pin was barely sticking out past the white plastic. I was ready to throw it away but now it works better than new
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice