The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Uwell Caliburn auto fire delay and airflow problems

Discussion in 'General Vaping Discussion' started by kisianik, Sep 11, 2019.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. kisianik

    kisianik Full Member

    Jun 28, 2019
    Hi
    I got myself second Caliburn and from the start I feel that auto firing is not as fast as my first one, just like a second or so behind. If I use the button it seems to be OK.

    Also, it feels more airy. I check the same pod on both devices and first one seems to have a bit more restrictive airflow. Or, due to late auto firing, I am inhaling first clean air instead of vape, and thus, the feeling of less restrictive airflow.

    And lastly, which is not a problem, but it is not feeling OK, second Caliburn pod latching thing feels more loose, where on the first, when I push pod into the slot, I can feel and hear distinctive click, on the second, just a very little bump and very shallow click.

    Would first, auto fire delay constitute good grounds for warranty replacement? I got it less than a week ago.

    Any thoughts?
     
  2. Toronnah

    Toronnah Super Member ECF Veteran

    Jan 10, 2012
    Canada
  3. kisianik

    kisianik Full Member

    Jun 28, 2019
    Doing it already. 1 sec push and release when I inhale to mimic autofire.
    I wonder is my problem is common.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice