eRoll wicking problem or flooding atty/battery?

Discussion in 'New Members Forum' started by charliep, Oct 12, 2013.

Thread Status:
Not open for further replies.
  1. charliep

    charliep Full Member

    Hi guys, I'm new here. Just got my first eRoll last week and I love it.. haven't smoked an analog for a week! :)

    Having a few problems though and just wondering what it is I'm doing wrong.

    A couple of times a day, it still produces a lot of vapour but is really cold and tasteless without a satisfying throat hit, as if it's not heating the juice properly. Sometimes if I take it apart and put it back together it starts working fine again, but that doesn't always fix it. I also get a horrible burnt taste occasionally which usually goes away after giving the cart a flick. I've tried cleaning and changing the atties, carts, batteries and different juices but have the same problem with all of them. I always prime the atty and have taken them all apart and they look pretty clean.

    Have looked through the threads in the eRoll forum, but can't work out if this would be due to a wicking problem or if I'm flooding the atty or battery. I'm sure this is down to user error, anyone got any ideas what I'm doing wrong that causes it to go cold and tasteless so often? Whenever it does this i get really tempted to smoke a real cigarette!
     
  2. mooreted

    mooreted Ultra Member ECF Veteran

    Never had much luck with those Ego-C type tanks. If you have thick juice it won't wick well. Also make sure you press the little tank into the atty pretty firmly. I found that I have to press harder than I thought I would.
     
  3. charliep

    charliep Full Member

    Thanks for the reply! I'm using fruit flavoured juices and inserting the tanks firmly so I don't think that is the problem. I've been reading through more threads in the eRoll forum and I guess it's just a cold vape compared to more powerful devices, but I could swear that the vapour gets colder the more I use it!

    Is there anything I can do to get warmer vapour from it, such as trying low resistance atomizers or different juices?
     
  4. Plum

    Plum Senior Member ECF Veteran

    Sometimes I actually have to loosen the fit of the tank on the eroll to get the atomizer to work properly, no idea why, maybe it's a vacuum created. It seems once I've done that, and got it going well, I can then push the tank back firmly and it continues to work.
    You could try posting in the eroll forum to get specific answers, as most there are pretty experienced with the eroll.
    Good luck
     
  5. alisa1970

    alisa1970 Vaping Master ECF Veteran

  6. Vapoor eyes er

    Vapoor eyes er ECF Guru ECF Veteran

    Good one Alisa. Have no experience with the eRoll but have encountered pressure issues with a carto tank- can lead to either flooding or dry hits.
     
  7. charliep

    charliep Full Member

    Thanks guys, I'll try out some juices with different PG/VG ratios and report back. The cold vapour is really annoying me, hope I find a solution soon!

    Also I would have posted this in the eRoll forum but can't as I haven't made enough posts yet.
     
  8. charliep

    charliep Full Member

    By the way, I tried out my mate's Jacvapour V1P yesterday and didn't have the same problem. I kind of wish I had gone with one of those instead as the temperature of the vapour made it feel pretty similar to smoking a cigarette.
     
  9. mooreted

    mooreted Ultra Member ECF Veteran

    Personally, I like a 2.5 ohm carto at 5v. I am also looking at the Vapor Zeus from Vapor4Life which also runs at 5v.
     
Thread Status:
Not open for further replies.

Share This Page