evic won't turn on

Discussion in 'eVic' started by hittman, May 6, 2013.

Thread Status:
Not open for further replies.
  1. hittman

    hittman ECF Guru Verified Member ECF Veteran

    Supporting member
    A friend here on the forum sent me their evic thinking that perhaps I could fix it. When I plug the control head without the battery attached into the computer it will come up and say charging/uploading but when the battery is attached the computer won't recognize it. The main problem is that about 95% of the time the evic won't turn on. When it does turn on then it works fine until the battery needs charging or if you turn the power off then it won't turn back on. I have tried a couple different batteries but it makes no difference. I'm not opposed to taking the unit apart if it is possible. I just haven't figured out yet how to get the top off of the control head yet. I did try a software reset like they recommend on the website. If something needs resoldered or something then that is no problem for me. Any advice is welcome.
     
  2. crxess

    crxess ECF Guru Verified Member ECF Veteran

    I'f your friend does not expect the eVic back do this.
    Take an old/dead EGO threaded device and crank it down tightly on the head. Grasping this and the head tightly in both hands start working opposing pressure back and forth. No prying. Don't pull. Just rocking pressure. It may release and pop off.

    If your friend expects it back - return it now.
     
  3. hittman

    hittman ECF Guru Verified Member ECF Veteran

    Supporting member
    Thanks. I don't think he expects it back and has replaced it already. I'll give that a shot.
     
: evic
Thread Status:
Not open for further replies.

Share This Page