Kanger toptank not working Please help

Discussion in 'Tanks, clearomizers and drop-in coils' started by Jonesmatt06, Jan 8, 2017.

Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Jonesmatt06

    Jonesmatt06 New Member

    Jan 8, 2017
    I have had a problem with kanger toptanks where they just stop working no matter what I do. They do not read on any mods and I have 4 mods I have tried them on. I have tried multiple coils including the different styles(occ-ssocc-rba). I have checked the pins and they are making contact. Mine was a toptank mini and my wife's did the same thing and it's a toptank nano. It's crazy that both are doing the same thing. If anyone has any other ideas please let me know
     
  2. drysprocket

    drysprocket Super Member Verified Member ECF Veteran

    Jul 11, 2014
    Los Angeles
    I can't help, but just wanted you to know that the same thing happened with a Protank 4. I had two of them new, and after a few weeks, one of them just stopped making a connection out of nowhere. No matter what I did (must have tried 8 mods and various coils) it just didn't work anymore. The other one was fine though. I think something is messed up with their 510's or pins somehow. Not sure what's up though. Just fyi.
     
  3. Jonesmatt06

    Jonesmatt06 New Member

    Jan 8, 2017
    Did you try switching the pins on them to see if maybe all it is was the pin?
     
  4. drysprocket

    drysprocket Super Member Verified Member ECF Veteran

    Jul 11, 2014
    Los Angeles
    Hmm, no, but good idea. I ended up getting rid of it.
     
  5. pappcam

    pappcam Super Member ECF Veteran

    Jun 16, 2015
    Canada
    I had a Toptank Mini where it wouldn't connect either. It was a bad 510 pin and no matter what I did I could not get it to connect with any coil or mod. I ended up getting a new base for the tank from Fasttech.
     
  6. Jonesmatt06

    Jonesmatt06 New Member

    Jan 8, 2017
    Makes no sense why it would do that. I also have a new base coming in,hope it works and stays working
     
  7. Cheallaigh

    Cheallaigh Ultra Member

    Aug 13, 2016
    Georgian Bay, Ontario
    i've got a couple of bases that are a bit screwy... one doesn't connect with anything so i use it as a RBA holder and a few that let rbas just spin on them, but still lock with factory coils... but i don't use them often anymore so the bases are now backups for my pro tank 4's(they're the same).
     

Share This Page