The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

1 day old 510 automatic not charging

Discussion in 'Joye 510' started by doctadrea, Dec 12, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. doctadrea

    doctadrea Super Member Verified Member ECF Veteran

    Dec 11, 2013
    Maui
    Please tell me there's a solution??
    It won't hit at all when I put on the cartomizer, but when I plug it in (tried 2 different chargers), it blinks a few times but the charger light stays green. Also, when plugged into the charger, the battery led glows very dimly instead of bright.

    20131212_031229[1].jpg

    Is it a dud? I just got it yesterday... thankfully I have 2, but does this happen alot? Should I expect my other one to die at any moment too?
     
  2. LX1X

    LX1X Super Member ECF Veteran

    Nov 15, 2013
    Fee State
    Can happen.. bad battery. QC now a days doesn't exist on cheap mass produces items.

    Contact where you got from and see if you can get replacement.
     
  3. doctadrea

    doctadrea Super Member Verified Member ECF Veteran

    Dec 11, 2013
    Maui
    Great. My first battery (ego) died after about a month. It wasn't easy, but I had some patches and held strong while I waited for these to come in the mail, but knowing that I might randomly be vapeless next week or an hour from now isn't very conducive to staying off the analogs. :(
    I'm on a fixed income and can't just run to the store and replace stuff. Here's hoping the vendor sends me a new one quickly, and that my working one continues to work at least until then. Gah.
    Thanks for the reply! Sorry I'm a cranky pants. :D
     
  4. MD_Boater

    MD_Boater Super Member ECF Veteran

    Rule #1 - Have a backup, and backups for your backups.

    I'm guilt of violating that after getting my MVP2. I leave the house with only it and fly without a net all day. Of course the pass through works, and I am usually near a USB charger cord for most of the day.
     
  5. zoiDman

    zoiDman My -0^10 = Nothing at All* ECF Veteran

    Supporting member
    Apr 16, 2010
    So-Cal
    It could be a Bad Battery. Or it could be that the Center Pole of the Battery is Not making a good contact with the Charger.

    Do you have a Multi-Meter or know someone who does to check the Battery? Is your Battery and Charger Under Warrantee?
     
  6. Switched

    Switched ECF Guru ECF Veteran

    Feb 18, 2010
    Dartmouth, NS Canada
    ... what voltage is your battery putting out?

    I used to have a saying...

    A vaper without a multi meter is like a Dr without a stethoscope, can't diagnose anything. That was 4 years ago :)

    New saying a vaper without a DMM is like a smoker without a lighter :)
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice