The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

650 batt not vaping, how do I fix?

Discussion in 'Bloog' started by WellAdjustedAndroid, Oct 25, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. WellAdjustedAndroid

    WellAdjustedAndroid Full Member

    Oct 10, 2013
    NY, NY
    I wanted to ask you guys on the forum here, see if I can figure out what I am doing/did wrong. I have a 650 I bought about a month ago. As of this morning, its not really vaping at all. Its like it won't hold a charge. But the flashing lights seem strange, so maybe I am doing something wrong.
    I put it on the charger for a few hours, and the light on the USB part turned green. I took about a vape and a half off it, and the button started flashing - and then, nothing. It felt like a dead battery feels, so I set it on the charger again...same thing. Is there something I have to press? I tried turning it off and back on. But I can't figure out how to get it back to its awesome 650 self!
    Thanks :)
  2. WarHawk-AVG

    WarHawk-AVG Vaping Master ECF Veteran

    Jul 27, 2013

    Give that a whirl

    Have you counted the flashes?
  3. Racehorse

    Racehorse ECF Guru Verified Member ECF Veteran

    Jul 12, 2012
    USA midwest
    Sounds like center pin got depressed and is not making contact with the charger as WarHawk suggests........


    A bad charger.

    If you can try to charge it on a friend's charger or somewhere?
  4. WellAdjustedAndroid

    WellAdjustedAndroid Full Member

    Oct 10, 2013
    NY, NY
    Ack. Didn't work :(

    I tried it and same thing. The fire button flashes briefly and then just fades out. If I try it 2 more times, the fire button then flashes at near full strength like 10 times. But it still doesn't fire.

    Does this help in the diagnosis?

    Thanks for your help :)

    Oh...and I don't have another charger with this particular thread to try. Its an ego clone batt but its an 808 thread like the Kanger vGo. I have a USB charger for a small 78mm standard 808D but I know it won't charge 650 mah.
  5. Burnie

    Burnie The Bug Man Verified Member ECF Veteran

    Jul 1, 2009
    Sunny Florida
    When I connect my EGO's to the charger, the light on "The EGO" will flash a few times to let me know it is connected. All 9 that I have do this. Some, the light on the EGO stays on, Some don't, but they ALL flash when I make connection. If It does not flash when connecting, it is not charging. If it is flashing when you connect it, and does not charge, you have a bad battery, buy another, or use the backup, or the backup of the backup. Batteries go bad, always have extras. Hope this helps

    Vape On
  6. WellAdjustedAndroid

    WellAdjustedAndroid Full Member

    Oct 10, 2013
    NY, NY
    I just tried it and it does flash when plugged in. The USB plug has a small light that is red when charging and green when charged. When I put it on the charger, the USB is red for a minute then turns green. But it behaves like it has no charge.

    Hmmm maybe it is just bad and I have to replace it. Ack, bummer. I like the 808 thread on an Ego clone. Its in my "go to work kit" so I can take bigger pulls than what my Bloog cigalike gets me - like when I go out for lunch and stuff. I can just switch the clearo or cart and don't have to carry extra clearos to switch between the "regular" cigalike 808 and the 650 mah 808.

    Bloog is moving to 510 threads too. I'm not sure how long they'll be selling the 1.6 ml 808 clearo.
  7. LeftHandBlack

    LeftHandBlack Super Member ECF Veteran

    Sep 17, 2013
    Brighton Co
    Time for a new battery. Get a Kanger Evod battery. They work better and last longer the EGO batteries. There are so many clones of the EGO T batteries out there and ,most are junk!
  8. Thunderball

    Thunderball Vaping Master Verified Member ECF Veteran

    May 5, 2013
    Grayson, Georgia
    They just go bad like that....for no apparant reason.... Chinese production. Ive had them last 6 months and had them last a week. This is why Burnie has 9 of them. Back ups.

    If you continue to use ego' a handfull of them.
  9. redempti0N

    redempti0N Ultra Member ECF Veteran

    Mar 16, 2010
    staten island USA
    Ive had this issue what I ended up doing was unscrewing the carto slightly and it worked fine.
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice