The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Build quality Heatvape Invader Mini?

Discussion in 'New Members Forum' started by buckwheat.phd, May 20, 2015.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. buckwheat.phd

    buckwheat.phd Full Member

    May 20, 2015
    Just picked up a HeatVape Invader Mini, so far it's a superior piece. Does everything it claims, and very well at that. I do have ONE nagging problem however, more of a PITA than anything else, but one that seems to be shared by two others I know that own one:

    The tactile feedback on the Fire button is dysfunctional. The button works, but only if you give it significant pressure. This has nothing to do with the silicone wrapper and such. It's just like a cell phone button - when you press it and get a -click-, you expect the button to have done something or made contact. Not on the Invader Mini. It takes further pressure, past the initial audible -click- sound and feel to make this contact.

    What happens is a light press on the fire button will give you a -click-, but no contact on the circuit board. Continuing with a VERY firm press will finally make the contact, and the unit will light off. But remember, I already had the tactile "feel" of a click, even though it didn't turn on.

    So the button "floats" between the click and the actual true on position. To demo to a friend, I pressed the button like 40x times with an audible click - but nothing happened. But sometimes it will turn on/off in that floating state, sort of like a light switch that's 1/2 way. It will sputter and the lights will flicker <-- when it does this, it will inadvertently shut the unit off, or put it into safe mode (5 clicks). Push it hard (white knuckles) and it will behave properly. I've noticed a lot of posts complaining that the Heatvape Invader unit "went into safe mode by itself". Well this partial engagement is what's going on.

    This is simply just a build quality and QA problem. It's a first run manufacturing issue, and I've heard every excuse in the world for it in the last few days - "it's supposed to be that way", "it's a safety feature", "it's a security feature", "it's the rubber on the outside", "it's because it's waterproof" etc. Hate to say it, but as fine a design and implementation that this unit really is, it's got a real first-run snag. I wouldn't tolerate it on a cell phone, a garage door opener, a flashlight or anything else with a tactile click that didn't complete the circuit.

    How annoying it is is subjective. The [very] kind fellow @ the vape store was alarmed when I casually brought it to his attention. He promptly pulled every one they had off the shelf and tried at least 15 - with the same results. I watched him box up about 50 new units and send them back to HeatVape. Obviously he wasn't impressed. Sure enough, a customer walked in and sheepishly tried to explain the same problem. Not sure what happened as I had already left.

    For me I can live with it, because the unit is that good otherwise. But I have a feeling a lot of folks will not be so tolerant over their $60 new gizmo.

    Would you send yours back?
     
  2. Thrasher

    Thrasher ECF Guru Verified Member ECF Veteran

    Oct 28, 2012
    Madeira beach, Fla
    I was very interested in this mod but it seems there's a few issues, look in general vaping and you can find my thread.

    Guess I'll wait for rev 2

    Just me but I'm not tolerant of the slop chinas dumping out lately.

    You have to decide if its worth living with.
     
    • Like Like x 1
  3. buckwheat.phd

    buckwheat.phd Full Member

    May 20, 2015
    Yep - saw that thread, very cool.

    I'll post back tomorrow when the temp sensing coils get here. I'm hoping this feature will really allow me the option of a cooler smoke, while still retaining the volume. But we'll see. I need to do some homework for similar units w/temp control. I could be missing the whole concept behind this.

    Does this particular unit use the new DNA40 board?
     
  4. tehdarkaura

    tehdarkaura Super Member Verified Member ECF Veteran

    Oct 12, 2014
    CO
    no its not a DNA40 -- its a china knock off of the DNA40 -- not a bad one though (if it was DNA40 the mod price would be less than the chip and it would max out at 40 watts instead of 50)

    I'm fairly happy with mine -- occasionally it will go to sleep and loose the settings, but thats not a big deal to me -- I tend to check mods after I pick them up or turn them on anyway. for the price I got it for its was too good to pass up for temp control and 50 watts
     
  5. mesamay2003

    mesamay2003 Super Member ECF Veteran

    Jan 30, 2015
    AZ, USA
    I didn't have any issues with the fire button on mine, although you did have to hit it in a certain spot and give it some pressure...I returned mine because of software issues/bugs and it would eat through batteries...
     
  6. buckwheat.phd

    buckwheat.phd Full Member

    May 20, 2015
    Yea, I've had all sorts of undocumented quirks with this Heatvape Invader Mini:
    • Sleep mode when it wants, forgets settings and makes you re-enter everything after about 8 hours of inactivity.
    • Waking the unit up is a chore that is firmware version dependent, and nobody knows how to perform
    • The buttons do not fully depress/engage after a click. That is just stupid QA (original post)
    • Huge parasitic battery drain (thus the sleep mode).
    • Other manufactures seem to have gotten around inactive battery drain, why not these guys?
    • The doc pamphlet it comes with is terrible. The font is close to 3 pt type and requires a magnifying glass. The English translation is hilarious, and worse all the instructions are just plain wrong
    • This device has gone through at least 3 major firmware revisions in just 4 weeks, and each one mangles the button sequences. And of course none of them are documented anywhere
    • IMHO this gadget is a great device - but they are WAY out in front of their own QA abilities. Their engineers are busy whacking out new code by the hour, and nobody knows what the heck they're doing. Not even anyone in their own company. Or which version shipped on what unit where and when
    • I have no idea what version of firmware is on the unit I own. And nowhere is it documented.
    • They post various stuff on their Facebook page, then never answer the questions or replies. Crazy
    I'll just wait for eLeaf to come out with a temperature controlled version of the iStick 50. I'll just be careful not to run over it with the car, which is essentially all the Invader really offers at this point lol
     
    • Like Like x 1
  7. Thrasher

    Thrasher ECF Guru Verified Member ECF Veteran

    Oct 28, 2012
    Madeira beach, Fla
    Well after watching busardos review it would seem there is already a revision 2 released.
    So have to wait for more reports
     
    • Like Like x 2
  8. Sarasotared

    Sarasotared Senior Member

    Feb 26, 2015
    Sarasota fl
    Checkout pbusardo's review I believe they fixed it and you can tell which version by the box
     
    • Like Like x 1
  9. T Glenn

    T Glenn Full Member

    May 24, 2015
    My Invader Mini has only shown one problem, it loses the settings when it goes to sleep sometimes. It is not enough of a problem to make me want to get rid of it. Aside from that it works well.
     
  10. John Semenek

    John Semenek New Member

    May 25, 2015
    Batavia, IL
    I have the same problem with the fire button, but using a firm press seems to work 99% of the time. In wattage mode in works great. Took it on a sailing trip in the Virgin Islands and it worked out stellar.

    The only issue I'm facing now is using a Kangertech mini with the Kangertech nickel coil I find the unit doing a strange thing. I have it set at 25.0W, 450F and 0.15 ohm. Works perfect after setting it as a new coil. After it goes to sleep, and I wake it up with the 5 clicks, the wattage when firing drops to 5W. I need to partially unscreww the Kanger, screww it back on, and set it again as a new coil. A real pain. I've heard there is a version 2 out already. I've contacted Heatvape to see if they will swap out my unit (which was a preorder) for the new version, but have not heard back yet. Has anyone else had the same problem? BTW: I've tried different batteries but all have the same results.
     
  11. roxynoodle

    roxynoodle Unregistered Supplier ECF Veteran

    Jun 19, 2014
    Ohio
    Yep, watch Busardo's review. He talks about the fire button being that way on the first version.
     
  12. John Semenek

    John Semenek New Member

    May 25, 2015
    Batavia, IL
    It will be interesting to see if Heatvape will allow me to upgrade to the newer version. I'll keep you posted.
     
  13. buckwheat.phd

    buckwheat.phd Full Member

    May 20, 2015
    Anyone have a quick link to the review if it's handy?
     
  14. buckwheat.phd

    buckwheat.phd Full Member

    May 20, 2015
    Yep - agreed. I've kept mine, now that I know of the little bugs I've trained myself to just deal with it. But with a temp coil (I'm using KangerTech Nickel 200), I'm having pretty good luck limiting the temp. Unless I'm doing something wrong or interpreting the wrong results, the temp max seems to be working quite well on the Invader Mini.

    It's just that about every time I use it, I have to go through the sleep/on routine, sometimes have to re-enter the coil parameters, sometimes even the power. But so far it has NOT forgotten the temp max

    Let's see what HeatVape has to say. I'll call and casually mention issues and see where that takes us. I'll certainly report back -
     
  15. John Semenek

    John Semenek New Member

    May 25, 2015
    Batavia, IL
  16. Shigura

    Shigura Super Member Verified Member ECF Veteran

    Jan 26, 2015
    Lincoln, NE
    Edit: lol seconds man seconds
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice