The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

CE4 not hitting right on Volcano Inferno

Discussion in 'Tanks, clearomizers and drop-in coils' started by b2darizzle, Jun 3, 2013.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. b2darizzle

    b2darizzle Senior Member ECF Veteran

    Jun 3, 2013
    New Orleans, LA
    I know there has to be tons of threads like this, but I figured I'd ask just for good measure.

    I've got a Volcano Inferno kit with a 650 and 1000 mAh battery with 510 threads. The tank system it came with works fine and even this Smoking Revolution clearomizer I found at a local head shop fits and works like it should even without taking off the stock O ring on the batteries. However, I just got in some CE4 clearomizers in and though they screw down fine, there's absolutely zero airflow.

    I've tried the untwist a half turn and that doesn't work either - as soon as the clearo sits on the battery, even without screwing on at all, the airflow is completely gone.

    One thing that works perfectly is the 510 adapter, but it adds a good half inch to the whole setup and looks funky. In comparison to the Smoking Revolution clearo, they look exactly the same, with the same airflow notches in the bottom.

    Shouldn't these things work right out the box if I have the correct battery to fit them? :confused:
  2. crxess

    crxess Grumpy Ole Man Verified Member ECF Veteran

    Sep 20, 2012
    Williamsport Md
    Remove the O-ring and give it a try.
    You are not getting air to the Bottom center opening of the CE4
    If the O-ring removal does not correct you will need to use the adapter to raise the ce4 off the battery a bit.

    It is the battery design at issue, not the CE4 which is standardized
  3. b2darizzle

    b2darizzle Senior Member ECF Veteran

    Jun 3, 2013
    New Orleans, LA
    That's kind of what I thought :( I saw some video of a guy using needle nose pliers to pull out the center tube at the bottom of the clearomizer a bit, but I thought I might have just received a defective product. Looks like Volcano just doesn't want you to use third-party items with their stuff :glare:
  4. Vapoor eyes er

    Vapoor eyes er ECF Guru ECF Veteran

    Sep 13, 2011
    Toronto, Ont.
    I found the CE4 to also give a very tight draw without an adapter on my eGo and Kgo. This was when they were the only available clearo and my solution was I carefully added/ drilled some air holes in the CE4 to loosen up the draw which worked.
  5. MrSelf Destruct

    MrSelf Destruct Super Member Verified Member ECF Veteran

    Feb 2, 2013
    Cobra Island
    My first kit was an ego-T kit with two batteries. One of the batteries I needed to use the adapter with any clearo and the other I did not. It didn't matter if I used CE4, CE5, Kanger T3 or Kanger MT3. It looks retarded but I just deal with it.
  6. crxess

    crxess Grumpy Ole Man Verified Member ECF Veteran

    Sep 20, 2012
    Williamsport Md
    If you look at Most Ego style batteries they have 4 slots to allow air, some cheaper only have 2.

    Though Volcano has the 4 slots, it has a very thick collar where Ego threading normally is and that O-ring. That area is effectively cutting off all air flow.

    I do believe, if the CE4 is dropping over the O-ring, removing it MAY allow it to work.
  7. sonicdsl

    sonicdsl Admin
    Reviewers Mgr
    Asst Classifieds Mgr
    Admin Verified Member ECF Veteran

    Supporting member
    Aug 11, 2011
    Moved to Clearomizers from New Members
Thread Status:
Not open for further replies.

Share This Page