The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Copper Nemesis clone won't fire!!

Discussion in 'Ask The Veterans' started by Dougk9589, Apr 30, 2014.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Dougk9589

    Dougk9589 Senior Member ECF Veteran

    Mar 8, 2014
    Binghamton Ny
    Hello everyone,

    I just received a copper nemesis clone in the mail from Fasttech and it will not fire. I have tried everything that I know of, I've tried adjusting the top contact, the bottom contact, flat top batteries and button top. I am using in 18650 mode. I have been Vaping for awhile now so I'm pretty good with troubleshooting my mods and nothing I do works so any help at all would be greatly appreciated.
  2. tmcase

    tmcase ECF Guru Verified Member ECF Veteran

    Apr 20, 2011
    Rave's neighbor!
    First if you haven't already swapped out the spring(s) in the switch for magnets, I would do that. Second, there is a beauty ring, very thin under the top cap. Remove that. It's useless and probably preventing your battery from making contact.
  3. steved5600

    steved5600 Ultra Member Verified Member ECF Veteran

    Sep 7, 2012
    Dallas, Texas
    LOL what tmcase said. LOL Also if you have a VOM volt ohm meter you can see if your getting voltage to the connector on top of the nemesis. If you are then your center pins are not making a connection. Solutions if the pin is adjustable on the atomizer adjust it. If not sometimes a 510 to 510 adapter will fix that. I have one Kayfun lite that the pin is a bit to high and it will not work on some of my mods. As soon as the present wick gives up i will fix that with either a new pin or add an insulator washer to fix it.
Thread Status:
Not open for further replies.

Share This Page