The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

evic vt 60 watt mod problem

Discussion in 'VV/VW APV Discussion' started by john1211, Feb 21, 2018.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. john1211

    john1211 Senior Member ECF Veteran

    Mar 1, 2013
    Troy, NY
    I have two of these and both have problems.
    One of them has a white screen, nothing but white screen, it does fire but of course cant see wattage, volts, battery life?
    The second one stops firing halfway thru a puff? It shows fully charged

    Any helps is greatly appreciated.
    Thanks
     
  2. Beamslider

    Beamslider Vaping Master Verified Member ECF Veteran

    May 29, 2017
    San Francisco
    • Agree Agree x 1
  3. bombastinator

    bombastinator ECF Guru Verified Member ECF Veteran

    Sep 12, 2010
    MN USA
    • Agree Agree x 1
  4. 93gc40

    93gc40 Vaping Master ECF Veteran

    Oct 5, 2014
    California
    One sounds like dead screen the other a dead battery.. Fwiw full voltage does not mean fully charged or good battery.

    Sent from my SCH-I605 using Tapatalk
     
    • Agree Agree x 2
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice