The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

RDA Leaking Velocity and servicing

Discussion in 'RDA' started by Johntodd, Jun 6, 2017.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Johntodd

    Johntodd Super Member ECF Veteran

    Jun 18, 2011
    USA
    I think my beloved Velocity is leaking through the 510.

    Can somebody throw me a link to that page where the unit is completely disassembled? I can't seem to find it. I just want to know what o-rings (and their sizes) to look for and replace.

    Thanks!
    -John
     
  2. Johntodd

    Johntodd Super Member ECF Veteran

    Jun 18, 2011
    USA
    Whoah! Slow down! Don't everybody talk at once. ;)
     
  3. r055co

    r055co Ultra Member Verified Member ECF Veteran

    Dec 24, 2015
    Seattle
    Probably because no one has had this issue, that and missing some essential information like

    Version?
    Authentic?
    Clone? and if so who made it?
    What have you done to troubleshoot the problem?

    If you want help you need to provide some basic information other than "leaks out of the 510 pin.

    Sent from my Nexus 6 using Tapatalk
     
    • Like Like x 1
  4. gpjoe

    gpjoe Ultra Member Verified Member ECF Veteran

    Oct 30, 2013
    Up North
    The o-rings on the Velocity are all the same size. I bought (and use) these 18mm x 1mm o-rings:

    Silicone O-ring 18 x 1mm Price for 25 pcs

    The inside diameter is 18mm, thickness is 1mm, which makes the outside diameter 20mm.

    That won't help leaking through the 510 connector though - there are no o-rings. Did you over-heat the atty and melt the insulator? If so, you need to contact Avid Vaper and order a new insulator set for the positive (510) pin.
     
    • Like Like x 1
  5. gpjoe

    gpjoe Ultra Member Verified Member ECF Veteran

    Oct 30, 2013
    Up North
    If it's a V2 and leaking with the grub screw installed in the 510 pin - don't know what to tell you.

    If it's a V1 or V2 and leaks from around the 510 when you squonk, try tightening the atty a bit more (don't force it). If it still leaks put a small drip-tip o-ring around the base of the 510 connector on the atty and re-install it on the mod.
     
    • Like Like x 1
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice