The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Smok Stick v8

Discussion in 'New Members Forum' started by mammoth sunflower, Jun 11, 2019.

Tags:
Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. mammoth sunflower

    mammoth sunflower New Member

    Jun 11, 2019
    I really need help, my base will not come off with my tank and i really need to change my coil! I’ve tried to find help with videos on youtube thinking that someone has had this experience and made a video about it, but i’ve had no luck. Their bases come off so easily and mine won’t budge! i’ve already tried many tools but it still hasn’t budged. ☹️ Someone please help. It’s a Smok Stick V8
     
    • Like Like x 2
  2. P3ch3

    P3ch3 Super Member

    Jan 31, 2019
    San Jose Costa Rica
    tanks base stuck on mod?
    can you post a pic, is a stick with the base attached?
     
  3. mammoth sunflower

    mammoth sunflower New Member

    Jun 11, 2019
     

    Attached Files:

  4. mammoth sunflower

    mammoth sunflower New Member

    Jun 11, 2019
    the paint came off when i tried the tools, i’ve been trying for like a week to get it off and have had multiple people try to get it off too! It just won’t budge and it’s very upsetting.
     
    • Like Like x 1
  5. P3ch3

    P3ch3 Super Member

    Jan 31, 2019
    San Jose Costa Rica
    upload_2019-6-11_10-19-57.png insert a pin, flat screw driver or somthing that fit on airflow hole, then try to take it out unscrewing, had something like that on a pen like that before, i was able to take it apart with a pin inserted there and used to pull or apply a bit force!

    Regards,
     
    • Agree Agree x 5
  6. TrollDragon

    TrollDragon Vaping Master ECF Veteran

    Dec 3, 2014
    NS, Canada
    Try putting a screw driver all the way through the open air slots and using that a sort of a T handle to unscrew the base. I haven't found one yet that won't come off with that method.
     
    • Agree Agree x 3
  7. Baditude

    Baditude ECF Guru ECF Veteran

    Apr 8, 2012
    Ridgeway, Ohio
    • Like Like x 1
  8. Topwater Elvis

    Topwater Elvis Vaping Master ECF Veteran

    Dec 26, 2012
    Texas
    If the tank base is so tight to the power device that channel locks/pliers won't unthread it mostly likely you will tear something up beyond repair during removal.

    Using flat stock or screwdriver through the airflow will certainly allow for a great deal of force to be used, be careful not to break the 510 connector off, or twist/rotate or dislodge the power device top cap to tube mating surface out of place.


    Or, just unthread the coil head from the chimney prime a new one & thread it back onto the chimney.
    Holding tank upside down fill tank, hold tank turn power device upside down & attempt to thread together.

    May work, may not.
     
    • Like Like x 2
    • Useful Useful x 2
  9. mammoth sunflower

    mammoth sunflower New Member

    Jun 11, 2019
    I got it off! Thank you everyone for your advice it means so much considering i almost threw it away by being fed up with it. Gloves and a small screwdriver works wonders!
     
    • Like Like x 4
    • Winner Winner x 4
  10. P3ch3

    P3ch3 Super Member

    Jan 31, 2019
    San Jose Costa Rica
    also you can try using rubber gloves and freezing the ato / mod some minutes before trying to unscrew! put it into freezer, it also helped me with stuck things to freeze them!
     
  11. Daniel Forsyth

    Daniel Forsyth Ultra Member

    Mar 26, 2019
    Victoria, Australia
    Welcome to ECF mammoth sunflower:thumbs:
     
  12. Coyote628

    Coyote628 Ultra Member ECF Veteran

    Sep 16, 2017
    Smok.....bah humbug!!!
     
  13. BrotherBob

    BrotherBob ECF Guru ECF Veteran

    Dec 24, 2014
    Sunnyvale,CA,USA
    Welcome and glad you joined.
     
  14. charlie1465

    charlie1465 Vaping Master ECF Veteran

    Welcome to the friendly bunch :)

    The experienced vaper syndrome strikes another blow for the desperate....again :D
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice