The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Vamo permanent fire

Discussion in 'VV/VW APV Discussion' started by FrostyDream, Feb 7, 2014.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. FrostyDream

    FrostyDream Full Member

    Feb 11, 2012
    United States
    My friend gave me his vamo that, when on, will fire non-stop until it's powered off. It's either a v1 or v2 clone. Is it the fire button itself? Can I solder a new one onto the PCB? I really want to make it work again. Tried stacked 18350s and a single sony VTC3 so I don't think it's the battery(s).
     
  2. natewesselink

    natewesselink Full Member Verified Member

    Feb 7, 2014
    northwest arkansas
    sounds like a possible short in the fire button itself. good luck getting a vamo apart, everything is press fit and with it being an aluminum clone youll probably end up destroying the outer tube itself before getting it apart. have you tried throwing it against something hard?(just kidding) when its powered on and fireing try to press the button. if it doesnt click the button is stuck. if it does then theres a short somewere on the device allowing the current to bypass the switch and youre probably SOL. just throw something you dont care about on the thing like an old carto or an old ce4 and useing a single battery power it on and check while its fireing.
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice