5V regulator issue please help

Discussion in 'Modding Forum' started by Solder-Meister, May 29, 2011.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    I have wired everything according to EZs diagram except I left the main switch as is on the negative side of the battery in 3x AA box from madvapes. Now when I flip the main switch from off to on, I hear the atty begin to burn slightly, not enough to produce good vapor, but enough to get hot and the regulator gets hot too. When I press the horn switch, the atty fires at the expected 5v but ive got to flip the main switch off to get it to stop. Ive got a few of these 378R05 regulators with control pin and tested them all on the breadboard with same results. I am using 470 ohm resistor, as indicated by the diagram. Anyone not having this issue, or is that how this is supposed to run?
     
  2. BuzzKill

    BuzzKill Unregistered Supplier ECF Veteran

    Joined:
    Nov 6, 2009
    Location:
    Central Coast Ca.
    you must have something wired wrong , go over it line by line to make sure it is wired correctly !
    can you post the circuit ?
    or a link
     
  3. WillyB

    WillyB Vaping Master ECF Veteran

    Joined:
    Oct 21, 2009
    Location:
    USA
    As Buzz noted you've made some subtle mistake.

    Is this how you wired it?

    [​IMG]
     
  4. CraigHB

    CraigHB Ultra Member ECF Veteran

    Joined:
    Jul 31, 2010
    Location:
    Reno, Nevada
    My first guess whould be the OP read the pin numbers wrong on the regulator, sometimes it can be hard to tell if pin 1 is on the left or right.
     
  5. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
  6. CraigHB

    CraigHB Ultra Member ECF Veteran

    Joined:
    Jul 31, 2010
    Location:
    Reno, Nevada
    Your diagram and pin numbers look right. Must be an error in the wiring.
     
  7. WillyB

    WillyB Vaping Master ECF Veteran

    Joined:
    Oct 21, 2009
    Location:
    USA
    [​IMG]

    We'll look at how it works, that my help.

    The 470Ω resistor pulls the Control pin to GND, disabling the output, The resistor keeps the connection from reading like a dead short and cuts the volts/current that the switch needs to handle. The CT pin (Vdis) only needs a few volts and ~20μA to enable the regulator. That's not much. Your problem has to here.

    Check with your meter at the output leg of your momentary switch when you turn on your master switch, there should be nothing/zero at this point. Maybe you cooked it a bit and it's leaking just enough current to kinda enable the reg.
     
  8. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    With cartomizer in place, main switch on, the atty is getting 2.33 volts. closing the momentary switch gives the atty 4.85 volts. I tried using a fresh switch with the same results. Also, want to point out that these are the 5A horn switches from madvapes. I even took the liberty of throwing a 10uf 10v multilayer ceramic capacitor (pins 2 + 3) into the mix and it seemed to improve the situation because the atty doesn't fire as hard when the main switch is on.

    I also wired the circuit without using the control switch and it works perfectly; main switch on, 0 volts and 4.95 volts when fired. I'd really love to be able to use tactile switches which is why I'm pulling my hair out trying to figure this one out. I'm running out of ideas.
     
  9. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    Quick question, kind of off topic. Do I need to worry about polarization with these ceramic capacitors? They are so tiny and there is no mark indicating poles.
     
  10. CraigHB

    CraigHB Ultra Member ECF Veteran

    Joined:
    Jul 31, 2010
    Location:
    Reno, Nevada
    Do what WillyB said and check the voltage on pin 4 when the momentary switch is closed and when it's open. Should be be zero when relaxed and battery voltage when pushed. If it's not, there's a problem with the switch circuit.

    It shouldn't work without the momemtary switch there so I don't really understand how it's working when you say it works without it. If you were jumping the switch, that would make sense.

    Possible you could be getting impedance or interference issues on the control pin by using long wires and a switch with large contacts like a horn switch. Try removing the switch and its wiring then jump pins 1 and 4 with a short piece of wire to see if that makes a difference.

    Data sheet says you don't necessarily need input or output caps, but just to make sure you're not getting some sort of wiring impedance or noise problem, you should try putting caps on both input and output right off the regulator pins 2-3 and 1-3. The data sheet recommends 47µF caps.

    If all else fails, try another regulator chip. Maybe that one is damaged or defective.

    When you do get it working, you'll need to use a 4.7K pull down resistor with a tactile switch. A 470 ohm resistor will result in too much current flow for most tactile switches.

    Ceramic caps are not polarized. You can connect either lead to the positive side. Tantalums and electrolytics are polarized and must be connected correctly.
     
  11. WillyB

    WillyB Vaping Master ECF Veteran

    Joined:
    Oct 21, 2009
    Location:
    USA
    I'll add that you should check the entire pulldown circuit also. From the CTpin > resistor> ground. Maybe there is a problem in that chain. Check continuity and the resistance.

    As CraigHB said there are better resistance choices but it should work as per MV's diagram.
     
  12. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    Not totally sure what to test exactly or what it should be reading, except Vout to Ground to be the regulated 5v, which it is. I tested with three of the same regulators and switches fresh out of the package. I know I gotta be doing something real dumb, because so many other people are successful. Anyways, below is a picture of the breadboard and how it's set up as well as a few results from the testing. Maybe someone with more experience, or at least someone who has already built this can tell me if I'm getting the correct readings with my voltmeter and I'm just doing something stupid (which is probably the case).

    Breadboard Picture

    *2x 14500 batteries both at 3.9 volts*
    1. Momentary Open; Ground (pin 3) > Vout (pin 2) = 2.5 volts
    2. Momentary Closed; CTL (pin 4) > Resistor (pin 3) = 6.3 volts
    3. Momentary Open; CTL (pin 4) > Resistor (pin 3) = 0 volts
    4. Momentary Closed; CTL (pin 4) > Switch Lead (pin 1) = 0 volts
    5. Momentary Open; CTL (pin 4) > Switch Lead (pin 1) = 7 volts
    6. Jumper (pins 1 + 4); CTL (pin 4) > Vout (pin 2) = 1.05 volts
    7. Jumper (pins 1 + 4); CTL (pin 4) > Resistor Lead (pin 3) = 6.12 volts
    8. Jumper (pins 1 + 4); CTL (pin 4) > Jumper = 0 volts
    9. Jumper (pins 1 + 4); Ground (pin 3) > Jumper = 6 volts
    10. Jumper (pins 1 + 4); Vout (pin 2) > Jumper = 4.9 volts

    During the tests the regulator got too hot to even touch. Is that normal? Does it get that hot from normal use?
     
  13. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    I'm assuming that these horn switches are normally open :p.

    If I can find some 47uf caps, I'll put those in the circuit. If not, I have 100uf 16v tantalum caps on the way.

    This may sound dumb, but is there a difference between ohm resistors and pull-down resistors?
     
  14. CraigHB

    CraigHB Ultra Member ECF Veteran

    Joined:
    Jul 31, 2010
    Location:
    Reno, Nevada
    Momentary switches are typically "normally open", in words, open or infinite resistance when relaxed and closed or zero resistance when pushed. However, you can get them normally closed as well.

    The 100uF tantalums should be fine. The data sheet recommends 47µF as a minumum, but you can go over that. Electrolytics would probably be best, they're cheaper. Tantalums are generally used only in applications that specifically call for them. There's a reason they're used specifically, but I won't confuse you with the details.

    When you say pull-down resistor, and the opposite, pull-up resistor, you're talking about an application, not a type of resistor. It just means the resistor is used either connected to ground (pull-down) or connected to supply voltage (pull-up).
     
  15. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    Thanks for clearing that up CraigHB. I found a couple 47uF electrolytic caps and tied them into the Vin and Vo, but power still leaks to the atty. Same thing with the 100uF tantalum caps. I even eliminated the main on/off switch and shortened the cables, still no cigar. I am considering just leaving the control pin open and integrating a mosfet with tactile switch, even though that feels redundant. I have about ten of these regulators, so if anyone wants to take a look at it personally, I'll be willing to send one to you.
     
  16. bstedh

    bstedh Ultra Member Verified Member ECF Veteran

    Joined:
    Apr 5, 2011
    Location:
    Northern Minnesota
    i'm not 100% sure but I think you might want to set the 470ohm resistor in series with the momentary switch instead of using it to pull the control pin down.

    never mind it's a disable pin not an enable pin. I think you may need to play with the value of the disable resistor to get it to quit being premature. =]
     
  17. bstedh

    bstedh Ultra Member Verified Member ECF Veteran

    Joined:
    Apr 5, 2011
    Location:
    Northern Minnesota
    http://www.fairchildsemi.com/ds/KA/KA378R05.pdf

    Edit again... I was reading the wrong section... >2V to activate <.8V to disable on the control pin. So my statement about putting the resistor in series with the switch should be valid. It just needs to be sized appropriately to give you about 2.4V on the control pin when activated.
    Try just removing the resistor to see if that shuts it off. I wouldn't hit the switch without a limiting resistor however.
     
  18. WillyB

    WillyB Vaping Master ECF Veteran

    Joined:
    Oct 21, 2009
    Location:
    USA
    You have to remember this is not some new circuit/mod/chip. Probably hundreds of boxes have been built following that MadVapes schematic with those exact values. These forums are littered with them.

    I imagine he followed this guide from well over a year ago.

    MadVapes e-Cig 'How To' - 5 Volt 3xAAA Box Mod by Ez Duzit
     
  19. AttyPops

    AttyPops Yeah, I type stuff. ECF Veteran

    Supporting member
    Joined:
    Jul 8, 2010
    Location:
    Hc Svnt Dracones - USA EST
    Did you say you had an LED on it? Is the LED wired to the ctrl pin? Remove LED for testing. If that doesn't work:

    Are you 100% sure your pull-down resistor is working? (I think it requires a pull-down... active high, off low... if the regulator is what I think it is). If you disconnect the regulator and put the batteries in with master switch on, do you get voltage at the atty with or without pushing the button? (do this on the breadboard 1st). This may help you find a short, or mis-wire.

    To confirm, when looking at the regulator from the front with pins down, the pins are input, output, ground, ctrl from left to right.
     
  20. Solder-Meister

    Solder-Meister Unregistered Supplier

    Joined:
    May 23, 2011
    Location:
    Virginia
    Correct. At first, I thought maybe that's how this thing is supposed to operate, but I've talked to so many others who have built this simple 5v mod using EZs tutorial and they aren't having this problem.

    Without the regulator (or LED) and using only one 14500 battery, I'm getting no voltage to the atty with the main switch on. Pressing the fire switch gives it the expected 4v current. I put the 470ohm resistor in series between the ground lead of the atty and negative side of the battery and it's not firing, so I assume it's still functioning. Not sure what you mean by "... active high, off low...".
     
: madvapes
Thread Status:
Not open for further replies.

Share This Page