1. Win Vaping gear! The ECF 15 Millionth Post contest

    We are fast approaching the 15 millionth ECF post and we have a contest to celebrate this huge landmark and amazing prizes to give out to our members! Head over to the official contest thread to see the rules and check out the prizes generously pledged by our registered suppliers on the prize announcement thread.

Copper nemesis clone will not fire!

Discussion in 'APV Discussion' started by Dougk9589, May 1, 2014.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. Dougk9589

    Dougk9589 Senior Member ECF Veteran

    Joined:
    Mar 8, 2014
    Location:
    Binghamton Ny
    So I just received a copper nemesis clone from Fasttech and it will not fire. I have tried adjusting the top and bottom contacts, button top and flat top batteries. I am using 18650 batteries I have been vaping for awhile now and I am pretty mechanically inclined so I would greatly appreciate any help to get this vaping. Also the tubes I am using are the two larger ones.
     
  2. Clark F

    Clark F Ultra Member Verified Member ECF Veteran

    Joined:
    Apr 18, 2014
    Location:
    Tempe, AZ
    I didn't buy mine from Fasttech but I had sorts of problems getting it to work. Wish I could tell you how I did it, but it was really just screwing around with it, adjusting, reajusting, etc. Then I installed the Magnet Upgrade, Switch Rice Pins, and the Top Cap Delrin Insulators. Couldn't get to work for 2 days, actually just got working again a hour ago.

    I ended up taking out the new insulators and put back in the old one. Charged the battery, made sure everything was snug but not to tight and it starting working.

    Sorry, I can't be of more help. I've taken it apart over a dozen times. All I can suggest is take it apart clean it good and make sure it is making contact with the battery.

    Good luck!
     
  3. vapnmuse

    vapnmuse Senior Member ECF Veteran

    Joined:
    Mar 6, 2014
    Location:
    central new jersey
    remove the top cap and loosen the top contact pin. screw your atty on to the cap flush, snug the top contact pin into the cap, screw cap/atty onto body of nemi, insert batt from bottom and snug up switch. If it still don't fire clean the entire mod with ketchup and try again
    ketchup removes oxidation from copper so don't laugh till u try it
    You can use any cleaner you like, but chances are there is some ketchup in your kitchen!
     
  4. vapnmuse

    vapnmuse Senior Member ECF Veteran

    Joined:
    Mar 6, 2014
    Location:
    central new jersey
    also make sure you remove the kick ring if your not using a kick. its the small ring between the main tubes and it does come off
     
  5. milescadre

    milescadre Super Member ECF Veteran

    Joined:
    Jan 29, 2014
    Location:
    Cincinnati, Ohio, USA
    I'd say with any plated version make sure there is no finish on the threads. Fastech somewhat rrecently stopped shipping the versions with the clear coating and I'd be willign to bet its because it stopped it from firing.

    Just about anything acidic will clean oxidation off copper, Ketchup is a great example because it has alot of vinegar. Believe it or not, if I am out of isypropyl I'll use vinegar to clean connections.

    When assembling, You want to attach the correct tube for your battery. The "core" tube (the one with the engraving) should obviously be on the bottom, then attach the approriate tube (the longer one for 18650, the shorter one for 18500, NONE for 18350). The Beauty ring (the shortest) is optional and not required. If kicking, add the shortest ring to either the 18350 or 18650 sizes, or use the longer tube for 18500.

    Then, set that aside and take oyur top cap. Completely unscrew the contact pin (but do not remove it) and begin threading your atty until it seats to the cap. Then, screw the center pin in until you get a good contact. I like to turn it a little more after that, that way its less likely to move.

    attach the top cap to the tube assembly, then insert your battery through the bottom of the mod. Positive side up. IF oyu have a kick, inser the kick via the top before attachign the cap, then insert the battery.

    The bottom switch will need adjustment. first, try screwing on the switch through the bottom until it seats on the battery. If you cannot actuate the switch and make the mod fire, you may need to unscrew the center pin a bit. If you seat and the switch doesnt go in enough (you got quite a bit of overhang or long throw), youm ay need ot screw the center pin in some. If the center pin is screwed in all the way and the switch throw is still a bit too long, consider attaching the beauty ring.

    After that, it should be assembled ^^


    Forgive my spelling errors, I'll throw up pics after work if peoples want.
     
  6. Dougk9589

    Dougk9589 Senior Member ECF Veteran

    Joined:
    Mar 8, 2014
    Location:
    Binghamton Ny
    Pics would be greatly appreciated, I have cleaned the contacts and put it together in every way I know possible in order to keep the battery from moving I have to thread the switch contact almost all the way out and then it doesn't have enough throw to fire. I am almost starting to wonder if the screws for the contacts are too short? Could that be a possibility?
     
  7. Nightshard

    Nightshard Super Member ECF Veteran

    Joined:
    May 31, 2013
    Location:
    Israel
    It's just about the top and bottom screws.
    There is no play with the top screw, it needs to touch the bottom of the atomizer or it wont fire.
    Connect your atomizer then screw the top screw in until it reaches the atomizer.
    Take the button out and see that when you push it the screw is pushed outwards beyond the rubber base, if it doesnt screw it a bit out but not too much.
    Now put the battery in and screw the button until you don't hear the battery rattle.
     
  8. zeroclue

    zeroclue Super Member ECF Veteran

    Joined:
    Oct 14, 2013
    Location:
    Barnsley, UK
    Did you remove the beauty ring? (Most likely cause).

    Are you using a kick? (If so, insert from the top and don't quite push it down far enough, it will move the rest of the way when you screw on the top cap).

    Can you post pics?
     
  9. thevyrus

    thevyrus Senior Member ECF Veteran

    Joined:
    Feb 11, 2013
    Location:
    new york
    removing "beauty ring" did wonders for me. I was able to tighten the firing post into the switch all the way, versus it having to barely being threaded on. Solved all my issues with this sexy beast of a cloned mod. Typical design flaw of such clones, but thankfully, as zeroclue mentioned, it is an easily resolved issue. Another option is filing down the lock ring a bit.
     
  10. thevyrus

    thevyrus Senior Member ECF Veteran

    Joined:
    Feb 11, 2013
    Location:
    new york
  11. Dougk9589

    Dougk9589 Senior Member ECF Veteran

    Joined:
    Mar 8, 2014
    Location:
    Binghamton Ny
    So I just took some pictures and you can find them here, DougKirkland's albums - Imgur

    So I finally got it to fire with a flat top battery, but the battery rattle is awful and I do not feel safe at all using the mod like that. I got rid of the rattle with a button top with the screw pretty much maxed out on the spring. Is their something that I am still missing or am I just not going to be able to use flat tops without replacing the contact pins??
     
  12. Dougk9589

    Dougk9589 Senior Member ECF Veteran

    Joined:
    Mar 8, 2014
    Location:
    Binghamton Ny
    Also if you look at the pictures I do have the beauty ring off if I am not mistaken.
     
  13. edyle

    edyle Vaping Master Verified Member ECF Veteran

    Joined:
    Oct 23, 2013
    Location:
    Port-of-Spain, Trinidad & Tobago
    lol

    sorry;
    am defitely going to rub some ketchup on some copper coins to see if that does work.


    !
    then! i'll stop laughing!
    lol
     
  14. edyle

    edyle Vaping Master Verified Member ECF Veteran

    Joined:
    Oct 23, 2013
    Location:
    Port-of-Spain, Trinidad & Tobago
    That sounds like the answer to the problem.

    You bottom spring got a bit too compressed; pull it up ; stretch it; it's not pushing hard enough on the battery for the top to make contact.
     
  15. Nightshard

    Nightshard Super Member ECF Veteran

    Joined:
    May 31, 2013
    Location:
    Israel
    This ring on the top is not a beauty ring, it lets you adjust the airflow and has nothing to do with the nemesis firing or not.
    TBH it looks silly with it off and that o-ring sticking out.

    The battery is not supposed to rattle, so you still got something wrong.
     
  16. bsoplinger

    bsoplinger Vaping Master Verified Member ECF Veteran

    Joined:
    Apr 13, 2010
    Location:
    Capitol District New York
    Pics did wonders. You do have the beauty ring still on. It's the shiny band part of what you have as the top cap. The actual top cap is the bit you've removed, which is designed to twist about the piece you have the RDA screwed into. The 2 holes are for airflow and you twist the missing piece around to line up or cover the holes for adjustment, not that you care with that dripper.

    Try rubber gloves or those rubber jar openers or similar. Grab the bit of the top cap where the o-ring is. Grab the shiney part below the line, twist it off. Then you should be good.

    Edited your pic, hope this helps:
    [​IMG]

    Sent from my Nexus 7 using Xparent Purple Tapatalk 2
     
  17. crxess

    crxess ECF Guru Verified Member ECF Veteran

    Joined:
    Sep 20, 2012
    Location:
    Williamsport Md
    :facepalm:

    Mechanical Mods are a simple ON/OFF system
    Multimeter is your friend. If you are at all mechanically inclined you can operate a Multimeter and easily troubleshoot a circuit.

    A) All contacts and threading must be clean and NOT coated in any non-conductive finish - some copper nemesis were clear coated.(bad idea)
    B) adjustments must be made to Assure everything can make contact when the switch is closed.
    Atomizer is part of the circuit - in through the center pin, through the coil, out the main body.
    Battery MUST be making good contact to top pin and Closed switch pin.

    Did you know - If you remove a bottom switch and touch the battery negative with the negative lead of a multimeter and place the multimeter positive lead on the Body of the Mod, it will read the voltage available?
    Yep, power is already available all the way back to the switch, just waiting for it to close.
     
  18. Clark F

    Clark F Ultra Member Verified Member ECF Veteran

    Joined:
    Apr 18, 2014
    Location:
    Tempe, AZ
    Doug, did ever get it vaping?
     
  19. Dougk9589

    Dougk9589 Senior Member ECF Veteran

    Joined:
    Mar 8, 2014
    Location:
    Binghamton Ny
    So guys I'm at work now and finally got it working. Long story short the beauty ring was seized on the onto the top connection and since I work in a machine shop I had to take two collets from a mill to get apart. Now it's vaping great and no rattle all I need to do now is get my switch a little smoother.
     
  20. Clark F

    Clark F Ultra Member Verified Member ECF Veteran

    Joined:
    Apr 18, 2014
    Location:
    Tempe, AZ
    Great! I'm glad you got it working.
     
Thread Status:
Not open for further replies.

Share This Page