eGo charger and/or battery problems

Discussion in 'Battery Issues' started by telsie, Jun 8, 2010.

Thread Status:
Not open for further replies.
  1. telsie

    telsie Super Member Verified Member ECF Veteran

    I got my eGo on Thursday and the first full charge for each battery gave me a glorious 10 hours of vaping each. Second time through one battery didn't charge at all — the indicator light on the charger never turned green, but I'd read these take about 3 hours to charge fully, so after like 4 hours, I removed it from the charger but it was dead. The other battery, however, gave me 8 hours of use on it's second charge.

    I charged the dud battery again and it seemed to be okay after about 3 hours on the charger (giving me about 8 hours of use). After that I lost track of which batt was which and had a couple normal cycles of use. Now, however, I'm back to problems. One battery wouldn't charge earlier and the other, on a full charge only gave me about 4 hours of use.

    Obviously, I've got something bad here that needs exchanging, but I'm trying to pinpoint what. My suspicion at the moment is that the charger itself is bad and simply not charging correctly (or at all) sometimes. The indicator light is no good, but even when I time the charges for at least 3 hours, it's a coin toss whether a battery will work, work for a few minutes, a few hours or for several hours.

    Anyone care to trouble shoot me? Or should I just send both batts and the charger back and start fresh?
     
  2. Kelemvor

    Kelemvor Ultra Member ECF Veteran

    did you already cleaned the threads on the battery ? i had similar problems, but after 1 or 2 weeks on one of my eGos.

    until now it happens 2 times more that a battery was down to soon and/or took no charge from the usb charger, but keeping the threads clean fixed it everytime.

    [edit] but i would exchange that charger, its not working correctly.
     
  3. Victor Frankenstein

    Victor Frankenstein Senior Member ECF Veteran

    Do you have a regular 510 charger that fits the eGo? They will charge the eGo batteries but it takes longer - but it will pin-point if it is the eGo charger or not.
     
  4. telsie

    telsie Super Member Verified Member ECF Veteran

    No, but they still look fine still — no visible build-up. I've only had these for a few days and had no juice leak at the atty-battery connection point.

    Yeah, I think it's likely the charger. I had a bad 510 charger once that caused some of my regular batteries to flake.
     
  5. telsie

    telsie Super Member Verified Member ECF Veteran

    Oh good idea. I'll try that on the next charging cycle (right now I'm using one battery while another is (hopefully) charging.
     
  6. m401 user

    m401 user Full Member ECF Veteran

    i had similiar problem, as i posted here
    http://www.e-cigarette-forum.com/forum/ask-veterans/96740-problem-ego-battery-charger.html
    nevermind what the answer was, i did solved this:
    the USB ports at front of my PC case seems to not have the required power
    to charge eGo, but when i connected charger to pc´s rear I/O panel, it recharged correctly. Must be the motherboard issue that it doesn´t put that +5V to front USB ports, so if you chrged yours on front panel of your desktop too, try this it will fix it.
     
  7. lorikay13

    lorikay13 Supplier Associate ECF Veteran

    Interesting....I'm having the same problem with my Riva. Already exchanged out the USB charger and cord. Am using a 2amp adapter on a surge suppresor so available power cannot be the issue. Wish I could know rather this warrents a return or not before my 14 days are up. I really love my Riva but hate to get stuck with a dud????
     
  8. telsie

    telsie Super Member Verified Member ECF Veteran

    I haven't charged mine through a USB port; I've just been using the AC wall adapter. So if the charger is the problem, it's got to be the charger itself in my case, not an issue with the voltage coming through it.


    I've got a new charger on the way, so I'll let you know if that solves my issues or not. If you've already gotten the charger replaced and are still having trouble, though, I think you've got a bad battery. I'd ask for a replacement.
     
  9. Whistle_Pig

    Whistle_Pig Ultra Member ECF Veteran

    If that's true on your PC, then you have defective front USB ports, or they aren't connected to the mobo at all.
     
  10. telsie

    telsie Super Member Verified Member ECF Veteran

    Cignot wasted no time in getting me a new charger since that seemed like the likely culprit. And I guess that's what the problem was because both batteries have been working consistently since I got that. I haven't had one refuse to charge again either. Yay.
     
Thread Status:
Not open for further replies.

Share This Page