1. Win Vaping gear! The ECF 15 Millionth Post contest

    We are fast approaching the 15 millionth ECF post and we have a contest to celebrate this huge landmark and amazing prizes to give out to our members! Head over to the official contest thread to see the rules and check out the prizes generously pledged by our registered suppliers on the prize announcement thread.

HELP! My ego-T Battery Stopped Working!!!

Discussion in 'Battery Issues' started by iwontgiveup, Mar 10, 2011.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. iwontgiveup

    iwontgiveup Full Member

    Joined:
    Feb 19, 2011
    Location:
    Toronto
    Hello Everyone,

    I bought my ego-T about 2 weeks ago and I absolutely love it. That was until today. I was just sitting there vaping, and when I went to take another drag, no vapor came out. I looked at the led on the battery and it was flashing (about 10-15 times). After it stopped flashing, it wouldn't turn on any more. So I thought the battery might have been dead, so I went to recharge it, but the charger lights up "green" and is reading it as fully charged.

    So I tried to vape it again, and nothing. It doesn't light up, charge, or vape any more. I'm a casual smoker, so I don't vape all day. Probably 1-4 times a day and I take really good care of it, so what could possibly be the problem??

    Thanks for your help everyone. :(
     
  2. Rosco

    Rosco Vaping Master ECF Veteran

    Joined:
    Dec 23, 2010
    Location:
    KCMO:>)
    My guess would be the battery up and croaked.
    I always -always have more spares than I need, just for occasions like this for one. I'd put a meter on it and test it. Which is another item I would never be without. A simple $6 ebay multimeter answers a multitude of questions when that need arises.

    Good luck.:thumb:
     
  3. greeneon

    greeneon Full Member

    Joined:
    Mar 10, 2011
    Location:
    Waldorf
    Don't giveup! Check it with a meter to be sure. If you don't have one, stop by your auto parts store or full service filling station or even a Radio Shack and have them test it.
     
  4. DaveP

    DaveP PV Master & Musician ECF Veteran

    Supporting member
    Joined:
    May 22, 2010
    Location:
    Central GA
    Try pressing the button 5 times, then put it on the charger.
     
  5. ymgie

    ymgie Senior Member ECF Veteran

    Joined:
    Jan 12, 2011
    Location:
    Utica NY
    If its what i think , you might want to try this first before you scrap it....
    This is the advice i got when i was having that problem with a riva 901

    What tends to happen is the center pin on the battery gets depressed too far, especially if using cartos or if an atty is screwed on too tight. The battery is probably fine, just that center pin needs pulling up, it looks a little like a screw head, you should be able to get a pin UNDER the head and pull it up, corner by corner. This should bring it closer to the charger center pin. This solves virtually all battery problems.

    hope it works for ya :)
     
  6. iwontgiveup

    iwontgiveup Full Member

    Joined:
    Feb 19, 2011
    Location:
    Toronto
    Thanks all for the help. Turns out the battery went into a recovery like mode, so I had to leave it charging for 8 straight hours in order for it to trigger back to operate fully. Who woulda thunk.
     
  7. ymgie

    ymgie Senior Member ECF Veteran

    Joined:
    Jan 12, 2011
    Location:
    Utica NY
    STRANGE ????????????????
    I went into recovery mode last night and slept for 9 hours before i could recharge myself :laugh:
     
  8. beandean

    beandean Senior Member

    Joined:
    Mar 8, 2011
    Location:
    Indianapolis,Indiana
    i just hadda 12 hour recover mode. yaaaawwwwwwwwnnnn
     
  9. iwontgiveup

    iwontgiveup Full Member

    Joined:
    Feb 19, 2011
    Location:
    Toronto
    Well yeah, I found it strange because the batteries were already fully charged and this happened out of nowhere. I barely vape, so it was definitely not because the battery was dead. Damn recovery modes!
     
  10. Sgt.Taz

    Sgt.Taz Senior Member Verified Member ECF Veteran

    Joined:
    Sep 5, 2010
    Location:
    Chicago,IL.
    Sounds like you got stuck in "OFF" mode. It happens when you click it repeatedly. putting it on the charger resets the safety switch. The click feature is new, but you might have a bad board in this one-if it does this again the circuit board might be the problem
     
  11. vinyl

    vinyl Full Member

    Joined:
    Mar 18, 2011
    Location:
    singapore
    I think I might be encountering the same problem, battery wasnt working fresh off the box, plug it into charger, led blinks then charger lights turn red. After fully charged (charger lights turns green), still not working, however when i plug it into the charger, led light blinks, charger lights go red for a few minutes before going back to green to show fully charged, any advice ppl? its a completely new battery.
     
Thread Status:
Not open for further replies.

Share This Page