mvp 2.0 trouble. please help me taste my juice again

Discussion in 'Variable Voltage APV Discussion' started by ThargorDraconis, Apr 26, 2014.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. ThargorDraconis

    ThargorDraconis Full Member

    Joined:
    Apr 13, 2014
    Location:
    sevierville, TN
    Just bought a shiny new mvp2.0 today and I'm at a complete loss on what to do with it.

    4 different juices, tried each in 4 different tanks, and they are all nasty!
    I have adjusted the volts, the watts, and no matter what the setting is they just taste nasty.
    Switched the tank to my kanger evod battery and they taste normal.

    I have no idea how that is even possible.
    Someone please explain what I am doing wrong lol.
     
  2. PaulBHC

    PaulBHC Ultra Member ECF Veteran

    Joined:
    Jan 22, 2014
    Location:
    Arizona
    Press and hold the P button to set watts. Press and hold the U button to set volts. With the P number or U number displayed you can press the button to advance through the numbers. Whichever button you press last is the setting it uses.
     
  3. ThargorDraconis

    ThargorDraconis Full Member

    Joined:
    Apr 13, 2014
    Location:
    sevierville, TN
    I actually understand how the unit works and that whatever the last setting I entered is the one it uses.
    either volt OR watts, not both.

    My real question is why would everything taste nasty no matter what setting I use on the MVP but everything tastes normal on the old evod battery?
    The evod is not vv or vw.

    I do appreciate the reply.
     
  4. Miata GT

    Miata GT Ultra Member Verified Member ECF Veteran

    Supporting member
    Joined:
    Nov 28, 2013
    Location:
    Largo, FL
    I started the same way as you, with eGo sticks. When I got my first APV, a SID which is vv/vw like the MVP2.0, I started by using the same voltage setting as the eGo would put out, 3.7 volts.

    I would suggest starting there and moving up slowly. You can check the resistance of your atty by pressing both buttons at once. What resistance are they? One rule of thumb says to add 2 to your resistance as a starting point for your voltage. I use 2.2 on my Provari and it hasn't let me down yet.
     
  5. PhatRon

    PhatRon Super Member Verified Member ECF Veteran

    Joined:
    Oct 14, 2013
    Location:
    Cumming, GA, USA
    What is the resistance of your coil and what tanks are you using? Also when you say nasty what exactly do you mean? Burnt?
     
  6. ThargorDraconis

    ThargorDraconis Full Member

    Joined:
    Apr 13, 2014
    Location:
    sevierville, TN
    I have been through every setting on both volts and watts on 4 different tanks.
    Tanks are evod that came in my starter kit, aspire bdc, iclear 16, and a brand new iclear X.1.
    I only get the burnt taste when I go too high on the settings, but no matter what setting I use it just didn't taste good at all. Barely any flavor at low settings and the higher I go the worse it tastes.
    I can't even get anything to come close to what I know it tastes like.

    Resistances range from 1.5 up to 2.1
     
  7. PaulBHC

    PaulBHC Ultra Member ECF Veteran

    Joined:
    Jan 22, 2014
    Location:
    Arizona
    I use Aspires with 1.8 coils at 7w with 50/50 juice 18mg.
     
  8. ThargorDraconis

    ThargorDraconis Full Member

    Joined:
    Apr 13, 2014
    Location:
    sevierville, TN
    Problem solved guys!
    Would like to thank everyone for the replies.

    Turned out to be a faulty unit.
    The MVP was only changing to the lowest and highest settings, nothing in the middle was working at all.
    Took it in to the shop this morning and had the guy try it, he tried it with the of his tanks and got the same result I had.
    Put a meter on it and it wasn't changing watts or volts.
    Tried a new MVP and it worked fine.
    He exchanged it for me with no problem and I am one very happy vapper!

    Thanks again guys!
     
  9. Pinggolfer

    Pinggolfer Vaping Master Verified Member ECF Veteran

    Joined:
    Jul 28, 2013
    Location:
    New York
    You are the first I know who has made that comment. Start off at 3.3 volts and work up.

    Sent from my SGH-T399 using Tapatalk
     
  10. ThargorDraconis

    ThargorDraconis Full Member

    Joined:
    Apr 13, 2014
    Location:
    sevierville, TN
    Like I said, it was a faulty unit.
    The new one works perfectly.
     
  11. DetraMental

    DetraMental Vaping Master ECF Veteran

    Joined:
    Mar 31, 2013
    Location:
    United States
    Glad you got it figured out!
     
  12. Frenchfry1942

    Frenchfry1942 Porch Vaper Verified Member ECF Veteran

    Supporting member
    Joined:
    Jan 12, 2014
    Location:
    Arizona
    Wow! Never heard of that before.
     
  13. Miata GT

    Miata GT Ultra Member Verified Member ECF Veteran

    Supporting member
    Joined:
    Nov 28, 2013
    Location:
    Largo, FL
    Awesome!+10
     
Thread Status:
Not open for further replies.

Share This Page