The costs of running this huge site are paid for by ads. Please consider registering and becoming a Supporting Member for an ad-free experience. Thanks, ECF team.

Apollo Vtube question-Button Intermittent

Discussion in 'Ask The Veterans' started by pita1028, Jul 2, 2012.

Thread Status:
Not open for further replies.
Image has been removed.
URL has been removed.
Email address has been removed.
Media has been removed.
  1. pita1028

    pita1028 Super Member Verified Member ECF Veteran

    Oct 7, 2011
    North Jersey
    I bought the Apollo Vtube a couple of weeks ago and couldn't be happier. But sometimes when I push the button to take a puff nothing happens. I'm ok with it if its supposed to do that (maybe a safety feature?). But the vets know best if there is something wrong or potentially wrong I I'd like to know so that I can contact Apollo.
     
  2. Kurt

    Kurt Quantum Vapyre ECF Veteran

    Sep 16, 2009
    Philadelphia
    I've not personally used a Vtube, but it seems to be very similar to the Lava Tube. It gets good reviews, other than a couple complaints about threading burrs. Looks very nice!

    Your problem may or may not be a real problem. I know my Echo will sometimes do this: press button, button lights, but either no firing or very little. Let the button light go off, try again, and its fine. It might be a safety feature with the vtube...seems to be one on the Echo...but it might be a problem. I would contact Apollo to be sure. If its not a problem they will know, and if it is, they will (or should) want to know.

    If any other vets have one of these, please chime in!
     
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice